Automatic backlinks (with manual insert option)

The automatic part doesn't insert backlinks into text.
Automatic backlinks are visible only in preview pane.
And they do not touch content of the note.
So if you don't use manual insert part all the notes stay the same with this plugin.


I didn't realize that. I held off on installing this plugin because I thought it was automatically adding backlinks to all my notes.

So is this plugin essentially a superset of your other backlinks plugin in that it does everything the other plugin (which I use) does, but in addition shows you backlinks (if they exist) for any note in a preview pane?

1 Like

I'm loving this plugin! Thank you so much for this!
Though, I am encountering a problem with hiding auto-backlinks section when there's no backlinks. When I have this option checked, the backlinks section disappear for all notes, regardless of whether they have backlinks or not.

I am on Joplin 1.7.11, plugin v2.0.3

Glad that this cleared it for you :slight_smile:

This is the same plugin with just different title. It has both manual and automatic way -i thought that automatic feature is more interesting to users so i made such title.

1 Like

Your welcome :slight_smile:

New version has this bug fixed, thanks for posting this.

1 Like

@ambrt thanks, works great! <3

A feature request, if I may: I'd really like the option to have the backlinks in a separate pane, instead of in the preview pane.

I also use the Outline plugin, that uses just such a pane to display a ToC, and this way I can see it all the time, not just at the bottom.
If it were in a separate pane, I could then use the standard Joplin layouting feature to place the backlinks in the same column.

Like this:

Any possibility of getting such a feature?


Hey, thanks for this plugin, the integration with the quick links plugin and the graph UI looks really promising.

I have one request, since the screenshot above from @zblesk shows my problem: Could we get rid of the ## in ## Backlinks when it's in the rendered panel only (automatic backlinks section header)? I understand the point when manually inserting the backlinks in the note body (actual markdown to style the header), but when it's the automatic backlinks section, which is only displayed in the preview panel, it feels a bit out of place.


Thanks for requests. Just released new version with panel and separate setting for automated Header (default is just Backlinks)


Just updated, it looks great! Thanks for the quick release.

1 Like

Yeah, thanks!

One more thing, is there a way to make it respect the current theme?

The ToC (top) does, but the blue backlinks are ilegible.



I've just noticed a slight problem with automatic backlinks.

They use ### or <h3>. You can use a span or style element, but using a header element messes up a note.

Imagine you don't use any headers/sections in a note, then a backlinks section looks like this:


Using any h? is a bad idea. Imagine someone using 2 or 4 levels. Why is the backlinks section on level 3? It also messes up the TOC. Please consider using a span or style element instead. Nothing prevents you to use a similar style as a h3 element. Just using the element itself is problematic.


Could the plugin simply honor markdown for the backlinks header?

For example, I'd love to use:
### Backlinks

That way, I'd have a very noticable separate section with a separator line.

1 Like

I've seen an anomaly with the latest update, which involves the panel showing even when the option here is unticked: Show backlinks in panel (might require restart)

In other words; the panel resize feature is present, obviously for showing backlinks in a panel, however this is still present even when the option is not ticked.

1 Like

I wonder if this is related to the "ghost panel" that some of us are experiencing. See discussion starting with this post and continuing for several posts:

1 Like

Ok, new version has html based header -
so if one needs h2 he can set <h2>My Header</h2> in plugins options.

This is important for manual and automatic headers. I'll try it out as soon as it is available in the repo.

1 Like

New version has html version. I don't know as of now how to reapply markdown to markdown header.
If you want horizontal line and ### header you can use new setting <hr><h3>Backlinks</h3>
This will look like here:

1 Like

I've tested this and it works. However, using h2 is the same as using ##. They will be added to the TOC.

So, I'm using the following for manual backlnks:


And the following for automatic:

\n<hr><span style="font-size: 120%; font-weight: bold;">Backlinks</span>\n
1 Like

Good work around :slight_smile:
I don't think that's possible to both have h-heading and have it not included in TOC.

TOC works on same array of parts that this plugin is inserting into, so markdown preview would have to have some order of execution order - like trigger TOC first then Backlinks.

Did you find / implement a way to ignore notes that are set up for the Overview Plugin?