Home    |    GitHub Page    |    API    |    FAQ

URL links don't work anymore?

I used to open URL links just fine by simply clicking on them.
But I noticed that in the latest releases this is not happening anymore.
I'm using Joplin 1.4.11
Is this a known change or bug?

It's a known change. Have a look at this:

The above GitHub post also makes reference to:

and

1 Like

Thank you @dpoulton

That explains it.
I save a lot of weblinks and being able to open them by just clicking on them it's quite handy.
I guess I need to get used to the extra step of adding the brackets from now on.
Maybe I'll finally start using the toolbar :slight_smile:!
image

The problem is with all the links I collected so far. It's quite some work to convert them all.

This is a bit bad. I haven't seen any platform that requires md links to be added with <>. . . Although I don’t use joplin's editor

maybe somebody comes up with a plugin to revert this change and enables auto-linking again.

In this 1.4.x, does it also not work (as before like 1.3.18) but in the WYSIWYG editor?

Edit: I mean, in the WYSIWYG if you paste (or type) an URL for ex, it doesn't make a link but a simple text? What about already copied/typed links?

That would be catastrophic for me.

There is no change to the WYSIWYG editor in this case, it only affects the markdown editor/viewer.

Another way is this

[url title](http://...)

Still, not as fast as simply pasting the URL address and have it already working as it used to be in the older releases.

So, if you really value the editing experience, why not choose an external editor?

I'm not sure to understand your question... I guess you're asking why am I using Joplin when I could use an external editor and go fully manual?

Oh that's great news, thanks!

Markdown-it options aren't yet exposed to the plugin API, although we could use the same method that Caleb implemented for the CodeMirror plugins.

1 Like

Although the change you did was not changing only the markdown-it option linkify, but a bunch of other stuff:

Update: Hmm, maybe unrelated stuff... ?

Yes the rest is just test units or cleaning up code for the tests. The key here is linkify = true/false

I've just tried to follow the thread and various tickets and am a bit confused. In the latest pre-release (1.4.11) I see I have to add tags etc. to get links to be clickable in the Markdown editor.

But in the WYSIWYG editor, actual links are also not created. The workflow is kind of a pain (paste, highlight, ctrl-k, paste again, etc.) for something that I believe, for many people, is a very common action. I know that my notes are litered with web links when researching something.

Is this indented behaviour? I would favour a toggle which applies to both/all editors for the behaviour of auto-linking URLs...

Maybe they're created but you don't see it?

It's what happens in 1.3.18 : it doesn't look like a link when pasted, but try to paste a link go to another note, come back, and the link then appears...

Of course I don't know (didn't try) about the 1.4.x behaviour...

I tried that based on your comments, but even switching notes doesn't change anything. No link is created.

I think there's two related but different issues here. One is about the Markdown editor and how the links should be rendered. The other is about the Rich Text editor and how the links should be saved to Markdown.

For the Markdown editor it's easy to solve and it might just be that we add an option to turn linkify on and off.

For the rich text editor, it's trickier. Part of the reason I made this change is that the Rich Text editor would not only display url-like text as a link, but also saves it as a link in Markdown, so if you type this:

https://example.com

it would save this as Markdown:

[https://example.com](https://example.com)

which I think is wrong, even more so when there are false positive and incorrect URLs are permanently saved to Markdown. So you'd end up with things like tsc --config [tsconfig.json](tsconfig.json) in your Markdown. It's difficult to solve because we can't just add an option and ignore the false positives since it's just not rendering, it's saved to the note.

Ok I think there are still unsolved issues with the linkify option and the change in behaviour might be too radical, so for now I've reverted this particular change: https://github.com/laurent22/joplin/commit/3f2fe79151ce4ba2bf2ee0d8ccd36404d28291b8

This appears to be a feature that is great for those that need it but a PITA for those that do not.

Could we go back to considering @tessus's original suggestion that a tick box is added to Tools > Options > Markdown that toggles linkify on for those that want it and off for those that don't? It seems just as valid a choice as a user choosing to enable/disable Multimarkdown, Mermaid, Fountain, Math, Emoji etc. These are all things that enhance Markdown but are not actually Markdown, just like linkify.