Quick Links Plugin

I'll see if I can add this.

3 Likes

I believe that with the latest pre-release, this plugin is not working.

I can confirm that it does not work in with the latest pre-release (v2.9.11) AppImage

I can't replicate this with the latest dev built from sources. Any errors in the console?

1 Like

For some reasons, I tried again today and it is working. Sorry for the false alarm. Could have been anything.

Same here, I ran the AppImage today and it worked fine :confused:

Really enjoying the plugin, but having trouble getting Notebooks to work. I have the option checked (and restarted Joplin), but it doesn't seem to bring up any notebooks in the search. Do they need to be recently modified like the notes do, or anything special?

No, it should work with any notebooks. What are the plugin and Joplin versions?

Joplin version is 2.88 (Windows).
Plugin version is 1.2.3.

When I type @@ to prompt the Link, and start typing a notebook name, none show up (despite the checkbox in options being checked).

Not sure what the issue could be tbh. Are there any errors in the log?

I think this might be relevant? Trying to click-unclick the "Include Notebooks" checkbox gives me this in the dev tools concole:

DevTools failed to load source map: Could not parse content for file:///C:/Users/###/AppData/Local/Programs/Joplin/resources/app.asar/gui/note-viewer/pluginAssets/mermaid/mermaid.min.js.map: Unexpected end of JSON input

(I replaced my name with ###)

Nah, that's totally irrelevant, that warning is always there with or without the plugin.

Speaking of which, what other plugins do you have?

Current plugins:

  • Auto tag
  • Note tabs
  • Persistent Editor Layout
  • Quick HTML tags
  • Templates
  • Text colorize

I actually uninstalled Quick Links for Create and go to #tags and @notebooks mostly to see if there was some issue with Indexing, but it seems to link to things correctly. I'm going to see if I can disable all other plugins besides Quick Links and see if that affects anything.

Disabling Notebooks (as upon reinstall it had been enabled):

17:20:49: RepositoryApi: findWorkingMirror: Using: https://raw.githubusercontent.com/joplin/plugins/master
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:20:54: SearchEngine: Updating FTS table...
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:20:54: models/Setting: Saving settings...
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:20:54: models/Setting: Settings have been saved.

Clicking "Show Notebooks" and hitting apply:

17:22:56: models/Setting: Saving settings...
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:22:56: models/Setting: Settings have been saved.
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:22:57: PluginRunner: Got message (3): joplin.settings.value showFolders
C:\Users\####\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\@joplin\lib\Logger.js:190 17:22:57: PluginRunner: Got message (3): joplin.data.get ['folders'] {fields: Array(2), page: 1

Yeah, still nothing. Again, typing @@ and then expecting to type in a Notebook's name for it to show up. Nothing.

Oh, I get it now! The plugin does not create links to notebooks only notes, the option is there only to show the notebook where each note is. E.g. if you have notes with the same name in different notebooks this helps you find the right one.

Ah okay, that's great to know! Sorry about that. Not saying you did anything wrong, but that might be something to clarify in the options (change the wording of "Show Notebooks" to something like "Include location in Notebooks" or something).

Finally, a workable writing method has been found, and that is

<a href="joplin://234c0c3205b743f189b539298f29fc5e">It works</a>

This method is from: Plugin: PlantUML - #23 by marc0l92

Just pushed a new version 1.2.4 where there's a setting to select the text. Apologies for the delay on this one, meant to do it earlier but life got in the way.