Copy Markdown link to active note

This simple extension allows for "Copy Markdown Link" keyboard shortcut.
Available below or in plugin search in few days.


This is great, although I almost think this should be part of Joplin core. Not sure why a shortcut was never added for this.


I assigned a shortcut (CTRL+M; also tried CTRL+ALT+M), but the note link isn't being copied into clipboard. When I use right click menu option, it does get copied into clipboard.

Joplin 1.7.9 (prod, win32)

Anyone else having this issue?

One thing i noted is that keyboard shortcut won't work if sidebar or note list is selected.
So basically it works only when editor is focused.
Is that the reason in your setup?
(I'm still on 1.7.6)

1 Like

Alt+L set as shortcut. But I gave both Ctrl+M and Ctrl+Shift+M a go, and they are good here.

Using: Joplin 1.7.9 (prod, linux)

The editor must have the focus, when you use the context menu you've already clicked the editor, but I've found if I switch from the rendered view, the shortcut will not work unless I click inside the note to focus it (and that's not a problem for me). I'm guessing you have something else going on, but thought to mention it just in case.


Yep, that was it, thanks. Once focus is in the editor, shortcut works.

Great little plugin by the way. Further streamlines working in Joplin.

1 Like

Hello, I like your plug-in very much. Excuse me, can this plug-in support copying links from notes to HTML? (I tried to paste directly into any part of the HTML, but failed)

Because I want the link of the note to become a part of HTML, just like the link picture in HTML '< img width = "20" height = "20" src = ": / 0a59a8315f1148fc9333d11badde2336" / >' so as to change its style.

Or is there any way to reference links to notes in HTML format? thank.

I really like this plugin, however it stopped working for me. Currently on Joplin 2.6.10 (prod, linux)


same thing here, plugin stopped working, currently using Joplin 2.8.8
does anyone have a solution?

1 Like

I've looked inside the plugin code and couldn't find anything that might cause the problem. Please someone tell me what is wrong here? This feature would be very useful if worked. I'm on Ubuntu 20.04, Joplin version now is 2.9.17

I've made one tiny change in @ambrt code and the plugin seems to be working for me now. Was I right about the change?

This plugin does not work in the latest version, can it be fixed? thank you

Is a plugin still required to copy a markdown link to the active note?

I agree with this earlier suggestion. Though I'd include a similar keyboard shortcut also for copying an external link to the active note.

Not working on version 2.13.9 :frowning: