Performance issue

Thanks a lot for all the energy you put in this great software...
I was furiously happy to see a trash and to put my nose into it (yes ! yes ! yes !). BUT... everything is now slow... slow... slow... !!! Six seconds exactly are needed to see the content (notes list) of a notebook for example when I clic on his name...
I tried to go back to the previous version of Joplin (2.14.20) but it's impossible ! Error message at the start of Joplin : they say something like that "the new profile is not compatible..." But I didn't created a new profile in the new version... Return to 3.0.2... It's starts again but still slow.
When I try to export all or just a part (.jex) of my datas they say (backup plugin) "not enough hard disk space". But it's wrong (1,5 Tera free for a nearly 2 Go .jex file !).
Same thing on the other windows 11 Pro (23H2) computer...
So : no more use of Joplin until now...
Someone with a similar issue ?
By the way : I had also the "no such folder" issue mentioned above with the subfolder draged droped to root..

Do you have any plugins, and does it help if you disable some of them? How about restarting in safe mode? (under the Help menu)

No plugin except Backup. I disabled it too (then stop and start Joplin) but still slow...
Same thing with safe mode... It's always incredibly slow too...

Do you have many tags? There's a known performance issue in this case, although this is not new.

If you open the console, are there any repeating messages or anything unusual?

I have about 500 (five hundred) tags...
There was 1,5 second (clic - action) delay before 3.0.2...
Now it's 6 seconds or more.

Yes there are repeating messages...
I don't use the sync function.
Here, I have only move a subnotebook to another subnotebook.

Here are a few other things to check:

  1. Exporting as JEX: Is it possible to export all notes using File > Export all > JEX. (The (backup plugin) "not enough hard disk space error suggests that the backup plugin might be attempting to create a backup on an external drive or other unexpected location).
  2. If you create a new profile using "File" > "Switch profile" > "Create new profile..." is Joplin slow in that new profile?
  3. Is the Joplin profile on a network or external drive? To see the location of the Joplin profile, go to "Help" then "open profile directory". The Joplin profile directory is the main place Joplin stores notes, tags, and other data.
  4. Is OCR newly enabled? (This probably isn't the issue — if it was, many OCR-related log messages would likely appear in the console).

"the new profile is not compatible..."

This message (or a similar one) is related to the version of Joplin's database. Joplin 3 updates the database to a version that is incompatible with previous versions of Joplin.

1 Like

I've just tried with 2000 tags and it's a bit slow, but slow like it always was and it takes about a second to open a notebook.

Could you also try this please?

  • First open the developer tools
  • Click on the "clear" icon:
  • Change the notebook

Then could you copy and paste the content of the console here? That may help us see what particular action is taking a lot of time

=> With a new profile it works very quick....

=> My Joplin profile is in the c: of my laptop without a lot of space.

=> No

OK... Nothing is similar from a test to another.

Everytime I only use the "export all" command from the File menu and NOT the "backup" command from the Tools menu.

Test n°1 : Backup plugin is ON and I export all => It doens't go to the end and I have an error message

Test n°2 : Backup plugin is OFF and I export all => it works

Test n°3 : Backup plugin is ON and I export all => (this time) it works.

BUT : not the same size of datas !!!

Test n°4 : Backup plugin is OFF again and I export all => it doesn't work ! A new message error and Joplin is out of service !

So : everytime it's different... And this time : no size problem !!!

work in progress... this evening
Like the "in case of issue, go back to previous version of Joplin" seems impossible (database version) and the backup not really clear, maybe we should alert all the users before to install the branch "3" of Joplin...

just a "me-too" here:

I did notice performance drop[^1] when switching from 2.14.19 to 3.0.2

An acquaintance of mine also noted that upgrade from 2.14.19 to 2.14.20 brought similar experience but I couldn't verify what was the reason there.

I assumed that it was plugins simultaneously rebuilding their cache (notelist preview), making backup etc

[1] OS itself barely responsive: cursor movements are slow, CPU approaching 100%, other apps take few seconds to respond to actions, notes opening is lagging for 10s of seconds.

However, after few minutes of work lags did stop and from that time it worked just fine

Upgrade 2.14.19 to 3.0.2 on different user (w/o plugins or data) but same machine didn't show performance drop.
Backup plugin worked just fine on both installations

Sync status

Not downloaded: 4435
Downloading: 0
Downloaded and decrypted: 481
Downloaded and encrypted: 0
Created locally: 38
Error: 0
Sync status (synced items / total items)
Note: 4896/4896
Folder: 158/158
Resource: 4954/4954
Tag: 38/38
NoteTag: 638/638
Revision: 545/546
Total: 11229/11230

computer specs
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 22.04.4 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: 82FN Yoga 6 13ARE05 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 6.5.0-26-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 2 days, 19 hours, 58 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 2542 (dpkg), 70 (flatpak), 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 5.1.16 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 2560x1440 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: GNOME 42.9 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Mutter 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   WM Theme: Adwaita 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Theme: Yaru-prussiangreen [GTK2/3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Icons: Yaru-prussiangreen [GTK2/3] 
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal: gnome-terminal 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: AMD Ryzen 5 PRO 4650U with Rade 
    .ossssssssssssssssssdMMMNysssso.       GPU: AMD ATI 03:00.0 Renoir 
      -+sssssssssssssssssyyyssss+-         Memory: 6571MiB / 7294MiB 

Any news ?

If you have this issue too then provide more information please. There's no point asking for news if we know nothing about the issue

My bad, I was just curious to know if the issue was solve or not

I made new tests. Same machine, OS, process, etc...
This time the "export all" from the File menu did the job...


So... Impossible to take a conclusion...
The only "difference" is the backup plugin was put to off before I reboot my machine.

Yes I had the same issue : all my computer became suddenly slow for some minutes... Not only JOPLIN. By my side I have no plugin at all and "backup" is off.
I'm doing some more tests...

I too noticed a major slowdown when I moved from 2.13.13 to 2.14. I have a small notebook of perhaps 6 notes at most (out of an entire collection of 2400 notes) that I use to track incoming purchases. When I receive notice that an item has shipped I merely stick a dash in front of the title so it moves to the top of the list (sorted by title.) Under 2.13 and previous versions the note list updated too fast to measure but as soon as I got onto 2.14 the time for the note list to update jumped to around 2 seconds. This is not a lot of time but the addition of 30+ megabytes to the installer and the almost two second delay in updating has me back at version 2.13.

I'm wondering if all the new "features" being requested are gradually pushing Joplin towards a Nevernote 10 type future where one makes a change and goes for coffee while things get updated.

  • Is the restoration process is OK for everyone (importation of a jex) ? -
    At this moment, the performance issue for me is first off all linked to the backup thing that doesn't work for the importation.
    The backup that I use is only the "Export all" command of the "File" menu. The backup plugin is off. Windows 11, Joplin 3.0.2.
    No battery saving. No screensaver.
  1. I export all into a .jex file.
    It works now and it's quick : 20 minutes for more than 2 Go.

  2. I try to import the jex file. It doesn't work : joplin never stop to import…

    At some moment (more than half an hour) I have an error message of timeout. Or... nothing ! (I tried many times and the behavior is not the same). During all the importation the computer is down (100 % processor).

  3. I did the import in my current profile first : doesn't work.
    I did the import in a new profile (created just for this use) : doesn't work.
    So : impossible to import !
    I put the jex file : on a USB external driver first, on the D second, and on the C third : always the same issue. At the end (4 or 5 hours) I need to stop Joplin… When Joplin stars again of course only a (small) part of my data are there.
    I install Joplin again : nothing different.
    At the beginning i was looking at the amount of data on the profile directory : it was normally increasing during the importation process.
    Two minutes later :

But at some moment it's impossible to access... The windows explorer is "out". I mean you can't enter the user profile.

Is the restoration process is OK for everyone ?
Why I want to export-import by the way ? To see if the delay using notes is less...
Now I continue tests on another machine (to be followed).

On a new computer (windows 11) I installed Joplin 2.14.20
I import one little .jex (215 Mo). The importation seems OK BUT at the end of the process there isan error message : "Backup plugin. Backup error for jex. Il n'y a pas de données à exporter. OK"
I did nothing except the importation...
To be followed...