Just upgraded my account to Pro... and the desktop app stops working

Operating system

macOS

Joplin version

2.14.20

Desktop version info

Joplin for Desktop

Copyright © 2016-2024 Laurent Cozic
Joplin 2.14.20 (prod, darwin)

Client ID: 9aafc9b803a44d79bc73e8bb931d0bc0
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0
Email Note: 1.2.2
Favorites: 1.3.2
Font Size Shortcut: 1.0.0
macOS theme: 1.3.13
Simple Highlighter: 1.0.0
Text Colorize: 1.2.3
Todoist to Joplin: 1.0.1

Sync target

Joplin Cloud

Editor

Rich Text Editor

What issue do you have?

Just upgraded to Joplin Pro and voila the desktop app stopped working. It loads my notes, and synchronizes fine but I am unable to create new notes or lists (the button appears as light blue rather than blue). What am I doing wrong? I've downloaded the app again and reinstalled it... still no luck.

Screenshots

Expand the notebooks and see which one is selected. I suspect it'll be "conflicts". If so, try switching to all notes or some other notebook.

1 Like

If Conflicts is selected in the above desktop screenshot, why doesn't the mobile app replicate this behavior? See: Notes created in Android Conflicts notebook don't stay there

Not sure what you mean. The UI in the mobile app is very different from desktop.

The desktop screenshot above shows New Note and New Todo buttons disabled. Based on your response, this seems like expected behavior with the Conflicts folder selected.

The mobile app doesn't disable those buttons, nor the + button that shows those buttons, when the Conflicts folder is selected. Based on your response, this seems like unexpected behavior.

Why doesn't the mobile app replicate the desktop behavior if new notes and todos shouldn't be created in the Conflicts folder?

It's not necessarily that it is expected (though it does make sense), it's just the only way I was able to replicate this behaviour.

There's an open issue and a PR to fix this: It should not be possible to create a new note from the trash · Issue #10188 · laurent22/joplin · GitHub

I wiped it, reinstalled it. It works now. I wonder if the problem was created by a system lag after I upgraded to Pro.