Sync not working in Mac Desktop App

I am using the Joplin Desktop App version 2.4.9 on Mac (Catalina 10.15.7). I synced to Joplin Cloud ~5,000 notes, originally exported from Evernote. The issue: the Desktop App does not display any Notes and Tags, although the account page on Joplin Cloud shows I am using ~9 GB of space and the local "resources" folder shows files too for several GB. Any advice?

From what you've shown me there's no note on Joplin Cloud, only resources. And you know to get help in support forums it's best to keep it short and provide specific info, logs, screenshots, etc.

Thanks, how about now for lenght?

lol, better, but you didn't have to. As I told you, you have 1500 resources in Joplin but no note apparently, probably because something went wrong in your first sync, or you didn't wait for it to finish.

Your best option would be to delete all your resources and sync, which should clear the data on Joplin Cloud. But for that you need some tool I guess. Perhaps @tessus could help with this? As he created a tool to automatically delete resources.

Thanks Laurent, I appreciate your patience and support so far.

If you are willing to try you can use this plugin I've just added, and that will help you delete all your data:

Basically you would do this:

  • First do a full sync with Joplin Cloud
  • Install and run Victor
  • Wait for everything to be deleted
  • Then wait for everything to synchronise - it's going to delete a lot of data on Joplin Cloud
  • Once that's done, you might want to close and re-open Joplin

At this point it should have a lot less data on Joplin Cloud, so you can import your ENEX file again, then sync again. This time make sure that it synchronises to completion and if there's any error post back here.

Thank you Laurent. This worked: Joplin Batch

Glad it worked, and indeed I see all your data is gone from Joplin Cloud.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.