Importing evernote .enex

Project Juniper Sewer.enex (116.5 KB) Joplin hangs when trying to import my recently exported evernote
notebooks.

attached is a sample enex.

Joplin 1.3.18 (prod, win32)

Client ID: 0b9bec0f4e564a0cbb56c1e945ac1450
Sync Version: 2
Profile Version: 34
Keychain Supported: Yes

Revision: 6b75485a1 (master)

It will be fixed in the next release. But I'm curious how that note was generated, because according to the timestamp it was last updated in 1 AD, but I think Evernote didn't exist back then :slight_smile: Was it generated by the actual Evernote app, or some other tool?

For the record, those are the timestamp:

    <created>20180323T163204Z</created>
    <updated>10101T000000Z</updated>
1 Like

I believe taht the note was created by ScanSnap , a scanning tool for the ScanSnap ix500 scanner, that
scans and imports into evernote.

By the way, it is a particularly good time to get the import working well because Evernote just came out with an update that disallows local notebooks, so people like me are faced with a choice of paying evernote a monthly fee or finding an alternate solution.

1 Like

Years ago they promised it will always be possible to use local storage. Hmm, ludckily I never believed them. I had it installed for exactly 2 minutes....

2 Likes

I hope they'll rot in Hell.

Please take my money Joplin team!

But first I really need this:
https://discourse.joplinapp.org/t/copy-paste-a-note-with-a-screen-copy-in-thunderbird-or-other-docs-makes-an-invalid-e-mail-doc/12519/2

Which is (it seems):

I really can't work without being able to copy/paste from the Note tool, please please please.
Thank you!


Edit BTW: if you're an Evernote user who upgraded too fast to its v10, they provide a Legacy install and procedure here:


Note: the Evernote Legacy app can be installed side-by-side with the new Evernote app.

Just had a browse of the Evernote forum after seeing the above. It appears that the latest version does so much more than just prevent local notebooks and, as far as the users are concerned, none of it appears to be good. A serious one is that EN takes over keyboard shortcuts and they cannot be changed, so users who use certain accented characters cannot type in their language whilst EN is running.

I only mention this as I have also seen posts where Joplin and other tools are listed as possible alternatives. Therefore there could possibly be more posts in the near future asking for EN features in Joplin, how to get EN data cleanly into Joplin, or (like @1001bricks above) a change that would enable them to leave EN behind.

2 Likes

I'm checking Joplin as Evernote alternative. I imported my full Evernote database successfully into Joplin V 1.4.19. :+1:
Yesterday, I tried the same import again with the latest release 1.5.11 . Unfortunately, the import blocks after 161 notes. Is this a known problem?

Log? https://joplinapp.org/debugging

1 Like

Just had similar issue - V1.4.19 imports ENEX successfully, but same files fail around half way through with V1.5.11

1 Like

Hi Laurent, thanks for the quick response. Evernote users are not used to that :wink:
It's an Uncaught TypeError: Cannot set property 'startedText' of undefined

-1609158400347.log (343.9 KB)

Thanks

Thanks @Nick1. Do you know by any chance what note is causing this and if so could you export it as ENEX and share it here?

It could help if the position or linenumber in the ENEX file would be logged. Is there anything like that already in the logfile? Maybe, I can open the enex file and count the notes or I can derive it from the notes already imported before. Do you know in what note order the Enex file has been build?

Hi Laurent,
I've filtered the culprit note out my list of 3610 notes. It's a web clipper note that doesn't look great in evernote as well. Line numbers or a file position in the ENEX file would have simplified the process :slight_smile:
Neck Pain Relief Exercise Video - YouTube.enex (299.5 KB)
After this debugging exercise, I can use the advise from this neck pain relief note :wink:

Thanks again for the instant support!

I think this issue was a regression in 1.5.11. Could you give a try to 1.5.12?

I had issues on Linux Mint whereby .enex import got stuck after 10 notes. This appeared to have fixed it.

It works, thanks again for the quick fix. I'm impressed!

I just imported my full evernote database as markdown in joplin V1.14
There is a big improvement in the import of Web Clipped Notes, sometimes these imported notes look even better than in Evernote V10 :slight_smile:
What I'm still missing is the source URL, is that already available in some way?

Yes, click on "i" button on the top right hand corner.

I started using Joplin just today - it froze importing my enex file from evernote - I saw the link for 1.5.12 - downloaded it - installed it - and everything imported. now to get past the learning curve.

Thank you so very much for producing this wonderful app!

Hi. I have some advanced import Qs and switching workflow questions, I'm an 11 year macOS Evernote premium user - I have 8100 notes in 159 notebooks and 12 stacks, and a great many cross-notebook cross-stack internal links to other notes, all Evernote app links not Evernote web links. Also, many local device file and folder file:/// links.

  1. What is the best way to quickly import or rercreate my Evernote stack and notebook hierarchy? I'd like to avoid 159 separate export-import operations. Should I add a tag to all notes in each stack, and a tag for each notebook, and then import all notes and manually move them? Is there a fully automated way to import the existing hierarchy?

  2. Will inter-note links be preserved?

  3. What happens to local device folder links (which Evernote v10 broke but Evernote legacy still lets me open up)?

  4. Any other "preparation" tips or suggestions? I'm assuming of course using Legacy Evernote for export. Other info that may be relevant - only a few of my notes have image (PNG, JPG) or PDF attachments, many notes have long lists of links-to-other-notes as "master project" notes as well as local-device folder links and local-device file links, and Evernote tables. Many web page clippings from news sites with complex HTML formatting that "looks" good in Evernote, sometimes I had to use capture entire page, sometimes capture article.

  5. Even though Joplin is open source, if I want to export from Joplin JEX to a proprietary app, are there any apps that accept JEX and preserve Joplin's native hierarchy and inter-note links, or plug-ins that convert Joplin JEX to another app's system preserving the hierarchy and inter-note links? FYI for the community / Laurent - Evernote making it harder in v10 to get my data out, is ironically one of my reasons for looking to switch! That, and, they dropped so many features without warning that the upgrade would do so.

Thank you.