Evernote import problem

I have just installed Joplin as I saw good reviews, it has no subscription, it is less bloated and I can choose to donate. I have been using Evernote and followed the instructions on importing notebooks (having reverted to Evernote legacy) however each time I only get one note imported from each of 2 simple notebooks, each with between 25 to 35 notes only. Have tried several times with the same result.
I am using Win 10 home and have the following info for the installation.

Joplin 2.7.13 (prod, win32)

Client ID: 0b2586f8b4b64747b6be690ee6ff8eee
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes

Revision: 5b5165d

Log file can be provided but as a new user I am limited to the size of post.

Please would someone advise if I have made an elementary mistake or if there is a way to resolve this.

Assuming you are using the .enex files to do the export/import, can you check to see if your notes are actually contained in the .enex file in the first place?
You should just be able to open it in notepad as it is essentially just XML.
You should be able to find individual notes via the titles in <note><title> and its data in <note><content>.
Just have a search to see if all the data you expect to see in the file is actually there or not.

Yes I'm using enex files (should have said)
I've just checked and you it seems that yes I only have one note in each of the notebook export enex files.

In which case it sounds like an Evernote export problem, the new electron app still allows you to export .enex (or at least it does as of 10.31.6 which is what I have installed still) so it might be worth trying with that rather than the legacy one.

Could you check the console to see if there's any warning while you import? How to enable debugging | Joplin

Edit: sorry I missed that's it's an Evernote export issue, so you don't need to do the above

Thanks both of you. Will check this when I get back.

Ok I have now reverted to an up to date copy of Evernote and this version does have the export all notes option. Before I installed the legacy version I think I had an older version before as the options are different now. It seems to have worked so thanks for the input.

Welcome to the bright side. We have unicorns (real ones), sunshine and cookies over here :rofl:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.