Home / GitHub Page

HOWTO: Change external editor?

#1

On the desktop app for MacOS, I’m given the option in settings for a text editor command, but there’s no documentation on how to fill this out. I’ve tried using the absolute path to my editor, and the command used to open my editor, but nothing has worked. Currently, I’m only able to have my note open in Xcode. How do I, for example, set my external editor as Visual Studio Code?

Thanks!

#2

Try to use the absolute path.

I’m using the following to use Sublime Text as the external editor: /Users/kct/bin/subl -n

2 Likes
#3

Awesome, thank you. For anyone else wondering, here’s what I had to use:

/usr/local/bin/code -n
1 Like
#4

Hi @sublimemarch and @tessus,

I assume your solution works when either Sublime or Visual Studio Code are installed through Homebrew on MacOS since I don’t have any executable named code on my MacOS.
I have installed Visual Studio Code through standard installation process in

/Applications

Would anybody have some guidance on how to get this configured, I have tried multiple options and keep getting the same error:

Error opening note in editor: spawn (whatever path to the executable I try) ENOENT

#5

code is most likely only a link anyway or a shell script pointing to the executable.

Anyway, look in /Applications/Visual Studio Code.app/Contents/MacOS. You should find an executable there which you can reference.

I don’t use Visual Studio, thus I can’t give you the exact answer. Btw, SublimeText cannot be installed via MacPorts or Homebrew.
Check your Visual Studio Code menu. Maybe there’s an item called something like 'install command line tool`.

Maybe someone who’s using Visual tuidio Code can give you a more definitive answer.

#6

Thanks @tessus - I ended up removing Visual Studio Code and install it again through homebrew.
It does indeed add the link that is used in Joplin

==> Moving App ‘Visual Studio Code.app’ to ‘/Applications/Visual Studio Code.app’.
==> Linking Binary ‘code’ to ‘/usr/local/bin/code’.
:beer: visual-studio-code was successfully installed!

It works fine after that.

#7

@taljoplin Can you please post what the link points to (as a reference)?

ls -la /usr/local/bin/code
#8

I was able to get the external editor working thanks to this thread. Thanks

I’m on an Mac. I use Dropbox and my objects are encrypted. My user has “Read & Write” permissions on the Dropbox folder. “staff” has “Read only” and “everyone” has “Read only”.

I’m getting this error.

I’m looking for ideas?

Thanks!

#9

Can you please open a new topic. Also, I’d kindly ask you to be a bit more specific. Is this error message from Joplin? From an external program, when you try to open a file in your Dropbox folder manually? From the editor when you click in Joplin on open in external editor?
Btw, Joplin does not open the file from your Dropbox folder, so this error is very strange.