Problem with editing (can't edit in the terminal's app)

Hello,
I just downloaded the app. Trying to use it in my terminal in my Ubuntu machine.
the problem is that I can’t edit, it throws an error:

edit: Error opening note in editor: spawnSync neovim ENOENT

As you can see I’m just trying to edit with my neovim editor.
Is someone familiar with the problem?

Try to use the absolute path.

1 Like

Hi man,
Thanks for responding!
How exactly do i set an absolute path? and where?
@tessus

check on the terminal, not in Joplin with the following command:

which neovim

You will get the absolute path. Then in Joplin terminal app, you type:

:config editor <absolute_path_here>

e.g. on my system:

$ which vim
/usr/bin/vim

:config edit /usr/bin/vim
2 Likes

Thank you, it worked! <3

You are welcome.

1 Like

Hi! I am having the same problem.

I am using joplin-cli on Ubuntu 20.04.

I attempted to set the editor to vim after finding the absolute path

$ which vim
/usr/bin/vim

Using the command

:config editor /usr/bin/vim

And I can see it is succesfully set when I run

:config editor

Because joplin outputs

editor = /usr/bin/vim

But I get the error

Error opening note in editor: spawnSync /usr/bin/vim ENOENT 

Whenever I try to open a note. This is replicated with nano (/usr/bin/nano) and vscode (/snap/bin/code).

I also cannot find how to reset the editor, so my app permanently breaks unless I remove and reinstall it.

Did you install from npm as per the documentation or did you download it from somewhere else?

Are you saying the app won't ever start again or that you can't edit the config again once you get it to this state? Not seen that before.
You can manually edit the config in ~/.config/joplin/settings.json

I had installed with Ubuntu software.

Installing following the doc instructions fixed the problem! Thank you for the quick response and the solution! I am a fan of this application, so being able to edit with external editors is a huge plus.

The app would start but I could not edit a note because I could not switch back to the original editor.

Great app, thanks!

I suspected this might be the case, I think the Ubuntu software app lists the flatpak (which isn't mainted by the Joplin team) and because of the sandboxing you would have to set other permissions first.