Error when opening External Editor


I’m using Joplin 1.0.125 (prod, darwin) on Mac 10.14.2. The contents are encrypted. The repository is DropBox.

I wanted to enable an external editor for some more complicated documents. I use an editor called iA Writer.

The precise configuration in Joplin is:

Text editor command "/Applications/iA Writer"

  • Open Joplin.
  • Select the Note I wish to edit.
  • Place the cursor the Note.
  • CMD E (using the mouse has the same effect)

I get this error which apparently comes from iA Writer:

If I change the editor to Sublime Text "/Applications/Sublime Text" everything works as expected.

While it looks like an iA Writer specific problem, maybe it’s a combination of several factors. Are there any errors in the debug log?

In my case the file is created as follows:

Anyway, can you try to open your note from Joplin with external editor set to Sublime Text. Then you will see that a file was created in that directory.
Now please try to open this file with iA Writer. Does this work?

Thanks for your help with this.


2019-01-27 09:10:20: "Reducer action", "NOTE_SELECT, 7bad43f333cd47a78f2a1c48235ebc43"
2019-01-27 09:10:25: "ResourceService::indexNoteResources: Start"
2019-01-27 09:10:25: "ResourceService::indexNoteResources: Completed"
2019-01-27 09:10:25: "ResourceService::deleteOrphanResources:", "[]"
2019-01-27 09:10:34: "Reducer action", "WINDOW_COMMAND"
2019-01-27 09:10:34: "Reducer action", "WINDOW_COMMAND"
2019-01-27 09:10:34: "ExternalEditWatcher: Event: add: /Users/dchristian/.config/joplin-desktop/tmp/"
2019-01-27 09:10:34: "Started editor with PID 23583"
2019-01-27 09:10:34: "Reducer action", "NOTE_FILE_WATCHER_ADD, 7bad43f333cd47a78f2a1c48235ebc43"
2019-01-27 09:10:34: "ExternalEditWatcher: Started watching /Users/dchristian/.config/joplin-desktop/tmp/"

And the file permissions:

-rw-r--r-- 1 dchristian staff 22542 Jan 27 09:10

I can open and edit the files in . /Users/dchristian/.config/joplin-desktop/tmp/

This is not ideal, but is manageable.


I figured this out, after doing a bit more searching.

the “Text editor command” should be altered to:

open -a "iA Writer"

Then everything is good.

Thanks for your help.

@cirrusnine I got exactly the same error and when I tried to alter the “Text editor command” following your solution, the command open -a "iA Writer" will be break to new line.

Do you happen to see this problem?

I tried to alter it again and it works.

I think Joplin the problem is Joplin automatically move anything recognized as a “arguments” to the “Arguments” field…