Android pre-release 2.9 is now available (Updated 23 October)

The new Android pre-release is now available with the below changes. The main changes are the work done by Henry on the new text editor, and the fix to filesystem sync.

The APK can be downloaded from there:

Changelog is there:


2 posts were merged into an existing topic: Pre-release v2.9 is now available (Updated 12 August)

With the filesystem sync fix, do we know if this also fixes the "export profile" function? I think this was broken due to the same issue. I'll test it when I have a chance but just wondering if anyone else has tried it.

I don't think anyone has checked yet, but I assume if it wasn't working it still won't be working because that code would need to be updated to use the new filesystem lib.

In which case we probably need to open (or check for an existing) issue detailing it (if it is still going on) as it might be relatively easy pickings for somebody and is a rather useful little feature.

A new version is available that includes the toolbar as well as filsystem sync fixes.

  • New: Add Markdown toolbar (#6753 by Henry Heino)
  • New: Add long-press tooltips (#6758 by Henry Heino)
  • Improved: Enable spellcheck by default on beta editor (#6778 by Henry Heino)
  • Improved: Setting to disable spellcheck in beta editor (#6780 by Henry Heino)
  • Fixed: Don't reload the application on screen rotation (#6737) (#6732 by Henry Heino)
  • Fixed: Fix default font in beta editor (#6760) (#6759 by Henry Heino)
  • Fixed: Fix side menu width on wide screen devices (#6662 by Tolulope Malomo)
  • Fixed: Fixed Android filesystem sync (resources) (#6789) (#6779 by @jd1378)
  • Fixed: Fixed handling of normal paths in filesystem sync (#6792) (#6791 by @jd1378)

Filesystem now working and syncing properly

1 Like

Unfortunately it does not work for me.

The API error I had before disappeared with 2.9.2. but the app syncs for around 20-30 minutes and then just said it completed. But it does not recognizes the files. It also does not show, how many files it synced. But also no errors.

Side info:

  • I have ~ some thousand notes (total files around 10000 in my joplin raw folder)
  • I am syncing them with syncthing locally to a folder in the internal Android storage
  • I already reset Joplin Android and point the sync location again to the internal folder where syncthing synced them.

It looks wrong.


That's quite strange... From the screencast above, it seems that list continuation only sometimes works. I'm not experiencing this issue (Android 12/Samsung OneUI 4).

List continuation is handled by CodeMirror's built-in markdown support. CodeMirror builds a syntax tree that represents the markdown document before enabling list continuation, etc. My guess as to what's going wrong is that CodeMirror isn't building a full syntax tree (though this normally happens quickly).

Is list continuation always broken or just sometimes?

Yes, he only performs well on the default language of my system. English is not the default language. I make mistakes when I enter English. I have never tried other languages.

The mobile phone system version is Android 10.

1 Like

Filesystem sync works now.

Attaching files doesn't work.
File type and location doesn't matter. I've tried with jpg, png, txt, json etc. Tried local and external storage. Doesn't work even with files in the sync target folder, even though the sync works.

Version 2.9.2
Android 11

v2.9.6 is now available:

1 Like

2.9 6 Android App has been CRASHED after choose menu Attach File

I can reproduce the crash on v2.9.6(prod) on my Android device.

I got these logs from Logcat
2022-10-29 10:03:27.672 9916-9946/? E/AndroidRuntime: FATAL EXCEPTION: mqt_native_modules
    Process: net.cozic.joplin, PID: 9916
    com.facebook.react.bridge.NativeArgumentsParseException: SafX.openDocument got 3 arguments, expected 4
        at com.facebook.react.bridge.JavaMethodWrapper.invoke(
        at com.facebook.react.bridge.JavaModuleWrapper.invoke(
        at Method)
        at android.os.Handler.handleCallback(
        at android.os.Handler.dispatchMessage(
        at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(
        at android.os.Looper.loopOnce(
        at android.os.Looper.loop(
        at com.facebook.react.bridge.queue.MessageQueueThreadImpl$
2022-10-29 10:03:27.673 4175-4330/? E/OOMEventManager: oom event not support this pkg, dismiss this!
2022-10-29 10:03:27.675 4175-8729/? W/MQSEventManager: jeoccur
2022-10-29 10:03:27.681 1500-5373/? W/ActivityTaskManager:   Force finishing activity net.cozic.joplin/.MainActivity

I checked the code of react-native-saf-x and it does take 3 arguments for every openDocument() function in native code. I found some information saying that NativeArgumentsParseException might be caused by a stale bundle of Android. I guess cleaning then building Joplin will fix this?

Unfortunately I don't know enough about Java to fix this but I've notified the contributor: Android: Fix note attachment issue by jd1378 · Pull Request #6932 · laurent22/joplin · GitHub

The file attachment crash is fixed in the latest version.