Wildly out of sync scrolling

I searched for this issue in past issues and on the forum and saw a long history of sync-scroll development, but it seemed to be marked solved. However, it is certainly still apparent and completely ruining live editing between the markdown editor and markdown viewer split view. When I scroll, or just type in the editor, it scrolls the viewer far past whatever I am editing, and if I scroll up it speeds way past before the thing I am editing. I know images and math cause this issue to occur, but this is like something isn't working right because The whole image is able to fit in view, so there isn't much reason the text line I am editing would be completely off screen. The images show how far it goes.

In these two images, I have highlighted the line I am trying to edit. It is below where the current viewer view is displaying.

Then I scroll exactly one step down, and the viewer is at the bottom of the document, with the line being completely off screen above.
The only way around this as far as I can tell is to just use the rich text editor. I'd prefer being able to disable sync-scroll to avoid this issue.

Joplin version: 2.8.8 or 2.9.11 beta
Platform: Linux
OS specifics: Appimage on Arch Linux
Steps to reproduce

Use markdown editor/viewer split view
Include images and text ( like what I have above )

I wish that wherever my cursor was would be the focus in the viewer. I tried a plugin that supposedly did that but it did nothing.

1 Like

Can you upload a note that exhibits this issue? As you've seen these edge cases are typically fixed, and it really helps the bug solver to have a note they can test against.

In the short term, you might find it helpful to know that the sync-scroll is syncing the first line of a note to the top of the viewer. So although it doesn't sync to the cursor, if you move the line you're editing up, it might align better.

That seems to be the secret I didn't get. If I add a bunch of newlines to the bottom of the document, the issue is basically fixed. It's when the editor scrollbar hits the bottom that it messes up the viewer. Thanks for the tip. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.