Webdav config / encryption config randomly lost on Android


I've been using Joplin for few years now with the latest config as follows

  • Joplin 1.1.4 on Linux x86 (Elementary OS / Ubuntu 18.04.x)
  • Joplin 1.1.4 on Windows 10
  • Joplin 1.1.2 on Android 10

Sync is done over Webdav (underlying is Nextcloud 18.0.7 latest stable)

On Android, since a month now I already lost three times - and for no apparent reason - the config about Webdav sync and encryption. It's sounds like the config from Joplin app / config menu has been wiped-out however I cannot figure out how.

This morning for example I had to re-type in the config sync configuration and encryption keys, then it worked perfectly. How come the config menu is reset?

Would you have any hints?

Thanks in advance,

Do you sometimes share images or text from other apps to Joplin?

Hi Laurent

Thanks for your quick feedback (and for your app!!).

Never shared images but text yes - I sometimes try to share some text in order to put it into a note.

Normally this is supported by Joplin right? To be honest I don't recall having shared text since yesterday (I saw the issue this morning again)

Hope this helps

I'm trying to understand what is causing this issue, which I can't replicate, and I wonder if it's linked to sharing data with the app. Do you remember if you shared some text before it lost the settings?

Hi Laurent

I just did a test ... and guess what ... I shared some text from another app to Joplin... and the configuration is gone!!!

So that's the issue - I now need to redo the config (.........) :slight_smile:

Can this issue be fixed quickly

Thanks a lot

Hi @laurent laurent,

i have the same problem, but i have not use sharing to joplin app on android.

Joplin: 1.1.2 on Android 10
log.txt (63.1 KB)

By the way, when it happens, do you only lose the sync settings or do you also lose other settings?

Not sure, because i have only set syncronisation settings (target and download behavior).
I have now disabled the "enable math expression" and next time I check if the setting is also reset.

1 Like


Just to add I'm pretty sure that I lost sync/encryption settings at least once without sharing any text between an external app and Joplin.

Hope this helps

this morning it happens again.

  • Sync settings reseted to default
  • enable math expression was reenabled
  • Welcome notebook was created and selected on the start
  • But I think not all settings are restetted to there default values, becaus the language setting is Englisch, but i think on the first instal it was German like the OS settings Andoid.

Wafter reconfigure the Synchronization, the sync start fetching all the 34609 items again.

syncReport.txt (35.3 KB)


Same here - happened this morning once again - sync settings and encryption settings are gone.

I'm sure I didn't do anything - just opened Joplin and settings were gone. By the way started downlading all the items again.

Are you relying on some external service for this info?


Same problem here. From time to time informations about Nextcloud-Syn are lost after starting the Android App.

Joplin 1.0.242 running on Ubuntu 20.4
Android-App Version 1.1.2

For those having this issue could you please try v1.2? https://github.com/laurent22/joplin-android/releases/tag/android-v1.2.3

I've changed the way the app is launched to prevent multiple instances from running at the same time as I suspect that's what the problem is.

1 Like

Sounds possible, if i think about it carefully this happened every time i switch back and forth between the apps.

I have installed the new version and observe the behavior.

I agree with @JackGruber here above: I tend to think this happens when you switch context (app) and this is why sharing text caused the issue. I installed v1.2.3 and I'll come back to this thread should the issue happen again (I just shared text with v1.2.3 and issue did not happen).


I'm pretty sure this is going to break sharing to Joplin

Either this or it won't help it all, most likely the latter.

The reason is singleInstance launch mode is set on the activity level, however sharing uses a different activity so this change will probably have no effect.

It's possible, I can't make sense of this part to be honest. This parameter solved certain multi-instance problems before (which, based on the log, seems to be what's happening here) so still worth a try. If if fixes the issue but breaks sharing, we can investigate at that point.

Removed current install. Installed 1.2.3 and setup sync/e2ee. Removed the "Welcome! (Mobile)" notebook. After sync and decrypt all is fine. Switched to Firefox and shared a link with Joplin (long press link, select Joplin). Joplin directly creates the "Welcome! (Mobile)" notebook and the settings are gone.

As I understand the issue is that a second instance (or perhaps activity? - but I'm not really familiar with this concept) of the app is created when sharing. And perhaps once two instances are running, it stays that way and strange things happen since the app is not designed for multiple instances accessing the db at the same time.

Do you have any suggestion on how we could fix this? For example is there any way, when sharing, to kill the current instance and create a new one?

I also have this issue on Android and Joplin 1.1.2.

Several times lately Joplin lose Webdav sync setup ( Nextcloud ) and the following also happens:

  1. It asks for my Dropbox sync credentials, although I dont use Dropbox.

  2. Encryption is set to "Disabled"

  3. After a while Joplin asks for the master key password (!) and after entering the password Joplin still says encryption is disabled.

  4. Save geolocation is set to on (I always have it set to off).