"Unsupported WebDAV URL format" ERROR

I get this error, but I’m sure that the URL is correct! (it follows the same format of Joplin’s example, too)
my WebDAV link is https://cloud.xplosionmind.tk/remote.php/dav/files/xplosionmind/.

MacOS app, version 1.0.179

What should I do? Is it a bug or it’s just my problem?
Thanks a lot!

I noticed that my webdav URL and the Joplin example in the FAQ do not have a trailing /

Have you tried https://cloud.xplosionmind.tk/remote.php/dav/files/xplosionmind ?

I already tried both with and without it, still the same.

https://cloud.xplosionmind.tk/remote.php/webdav/files/xplosionmind

Try using webdav not dav I did not notice that last time…

Edit: That’s odd my NC18 box now shows the dav url with dav but my Joplin client has always used webdav which I am sure is what it was on a previous NC version when I set Joplin up…

1 Like

I now wish I hadn't started this :slightly_smiling_face:

If I try to sync Joplin using a webdav URL with dav I get the same error as you.

If I test the sync in Joplin using the webdav URL with webdav, a URL that has been working for ages, I get another error where it looks like Joplin is pulling down the NC login page. However if I ignore it Joplin does sync.

I have no idea what is at fault here Joplin, Nextcloud or both!

1 Like

Experiencing the same issue, here. Nothing changes.
Maybe @tessus could give us some advice.

It popped up in my mind that maybe installing Joplin WEB API for Nextcloud could help, but even if I can’t: the latest supported version of Nextcloud is 17, I have Nextcloud 18. Btw probably it has nothing to do with this problem anyway.

Apologies for not understanding but did you try using webdav rather than dav in the URL?

https://cloud.xplosionmind.tk/remote.php/webdav/files/xplosionmind

For me using webdav rather than dav kicks up a lengthy error, but it does work.

I get this:

Cannot parse JSON: <!DOCTYPE html>
<html class="ng-csp" data-placeholder-focus="false" lang="en" data-locale="it_IT" >
	<head data-user="xplosionmind" data-user-displayname="Tommi Boom" data-requesttoken="sYg7cQ8maYBa8huFDmrXj9B5eNIywWbTl2W1OIURqBs=:xuBuFmxxD+0u2X/yXgeD9aNPDOpH+FK65x/9WsdkzFI=">
		<meta charset="utf-8">
		<title>
			Files - Nextcloud		</title>
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0">
				<meta name="apple-itunes-app" content="app-id=1125420102">
				<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
		<meta name="apple-mobile-web-app-title" content="Nextcloud">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="theme-color" content="#0082c9">
		<link rel="icon" href="/core/img/favicon.ico">
		<link rel="apple-touch-icon" href="/core/img/favicon-touch.png">
		<link rel="mask-icon" sizes="any" href="/core/img/favicon-mask.svg" color="#0082c9">
		<link rel="manifest" href="/index.php/apps/theming/manifest?v=0">
		<link rel="stylesheet" href="/index.php/css/core/c5cb-7380-server.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/index.php/css/core/c5cb-7380-css-variables.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/apps/apporder/css/apporder.css?v=778cf622-0">
<link rel="stylesheet" href="/apps/files_pdfviewer/css/style.css?v=6a154fe0-0">
<link rel="stylesheet" href="/index.php/css/core/c5cb-7380-results.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/index.php/css/files/9eeb-7380-merged.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/index.php/css/files_linkeditor/42f3-7380-merged.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/apps/files_rightclick/css/app.css?v=5e585c9e-0">
<link rel="stylesheet" href="/apps/metadata/css/tabview.css?v=030bb5ff-0">
<link rel="stylesheet" href="/index.php/css/files_sharing/c5f2-7380-icons.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
<link rel="stylesheet" href="/index.php/css/activity/6c1e-7380-style.css?v=b92d206521717ac032f8aa58d3c7ff2f-6348b1fb-0">
		<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/index.php/core/js/oc.js?v=6348b1fb"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/js/dist/main.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/index.php/js/core/merged-template-prepend.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/search/js/search.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/js/backgroundjobs.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/encryption/js/encryption.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_sharing/js/dist/main.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/apporder/js/apporder.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_pdfviewer/js/previewplugin.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_videoplayer/js/main.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/search/js/searchprovider.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/js/files/fileinfo.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/js/files/client.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/index.php/js/files/merged-index.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_sharing/js/dist/collaboration.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/camerarawpreviews/js/register-viewer.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/core/js/dist/systemtags.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/systemtags/js/systemtags.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/federatedfilesharing/js/external.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/index.php/js/files_linkeditor/merged.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_rightclick/js/script.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_rightclick/js/files.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/metadata/js/tabview.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/metadata/js/plugin.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/recommendations/js/main.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/socialsharing_email/js/socialsharingemail.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/comments/js/comments.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC85V3Nka3pGST0=" defer src="/apps/files_versions/js/files_versions.js?v=6348b1fb-0"></script>
<script nonce="c1lnN2NROG1hWUJhOGh1RkRtclhqOUI1ZU5JeXdXYlRsMlcxT0lVUnFCcz06eHVCdUZteHhEKzB1MlgveVhnZUQ5YU5QRE9wSCtGSzY1eC8

Yes, that is what I meant above by

Although an error was given sync did work afterwards.

I think I have found a way to sync to Nextcloud 18 without errors. Nextcloud’s webdav urls have changed since I first synced Joplin (and, it seems, since the Joplin FAQ was written)

  1. Do NOT use the Nextcloud sync option use WEBDAV
  2. For the webdav URL use the one EXACTLY as provided by the Nextcloud File app’s “Settings”. DO NOT add the “Joplin” folder path. It will look like https://<url>/remote.php/dav/files/<username>/ Where <url> and <username> refer to your Nextcloud server URL and the user account you are using.
  3. Enter the unaltered webdav url and your NC username and password and press “Check synchronisation configuration”. You should get confirmation all is well
  4. ADD the Joplin folder path to the end of the webdav url so it now looks like https://<url>/remote.php/dav/files/<username>/Joplin/ (or whatever the name is of the folder you are using for your Joplin notes)
  5. Press “Check synchronisation configuration” again. You should get confirmation all is well
  6. Press “OK” or “Apply” to confirm the settings
  7. Sync the client

If you add the Joplin folder name before your first sync configuration check you will get an error.

I did not find this due to any “leet” coding or webdav “skilz”. I just kept trying different permutations until it worked…

2 Likes

I will have to run some tests. I never ran into this issue, but I setup my sync over a year ago.

Btw, the link that uses webdav in the URL does not include a username, only the one that includes dav.

So it’s either one of these two:

  • https://cloud.xplosionmind.tk/remote.php/webdav/files/Joplin
  • https://cloud.xplosionmind.tk/remote.php/dav/files/xplosionmind/Joplin

It worked! I actually have no idea at all why this didn’t work with the Nextcloud option.
Btw, thanks a lot for your help @dpoulton and @tessus.

Have a nice evening

See, very strange. I use the Nextcloud option and not webdav.

@laurent we might have to look into this. Something doesn’t sound right.

So did I. Had set it up ages ago. Today, with “Nextcloud” sync working, I went to the sync settings page. I saw that the last sync test result was unknown. I pressed the test and got an error that webdav was not configured properly even though sync worked and continued to work. The last test result now showed as error.

After much faffing about I found that the easiest way to get an error free setup was to use the instructions for webdav as per the Joplin FAQ (using the /webdav/ URL without the account name) but using the Webdav connector and not Nextcloud.

Joplin: 1.0.179 (Win10)
Nextcloud: 18.0.1

My solution to continue using the nextcloud adapter was to backup my local copy of my notes to a jex. Then remove the /Joplin sub directory from my dav address. Proceed to sync it then was able to connect to my nextcloud instance again. After that I re-added the /Joplin sub directory to the dav address and re-synced. Once it started to populate the /joplin folder i just imported my backup and deleted the conflicts.

1 Like

I changed synchronization target from Nextcloud to Webdav to fix the issue

I am using linux on the desktop and android with my own nextcloud server with every variation of the url and none with work. Now that tomboy and ownnote have been abandoned I thought I would try this. https://myserverurl/nextcloud/remote.php/webdav/files/$USERNAME/joplin Any help?

The solution which worked for me is this one.

It was nice to have something that works with any iteration of Joplin, in this case, the appimage that runs on the linux desktop. Sadly, I tried it with the Joplin app for the android and it wouldn't work.

This Nextcloud WebDAV URL using Nextcloud Synchronization target helped me to sync without any issue:

https://<your-nextcloud-domain>/remote.php/webdav/joplin