Just another tropic: Linux -> Nextcloud!


I’m also having problems with sync from Joplin to Nextcloud!

Im running the last version of Joplin 1.0.201 (Linux Mint 19)

And running last version of NextCLoud 18.0.4

I have downloaded the “Joplin Web API” version 0.0.25 and installed / activated in nextcloud.

I have creted a folder in the root of the files called Joplin


Here is my settings from Joplin!

Any help will be good.

Kind regards


HI :slight_smile:

What did this mean: (post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Looking at the code it seems Joplin expects your WebDAV URL to contain /remote.php/webdav:

Hi @roman_r_m

Thanks for your answer :slight_smile:

I have changed the URL: https://MY-URL/remote.php/webdav/files/Taxick/Joplin

And now will it not accept my username and password...

but the other check I have problems with before are ok now..

What now? What can i do?

I misread your issue and was giving bad advice that wouldn’t be useful, so redacted it. I jump in too quick at times. Ha

He he okay :slight_smile:

I believe that if you have webdav in your Nextcloud URL you do not need your username. Try:


I think that we have to fix the Nextcloud web dav URL stuff at one point. A lot of people reported that they actually cannot use the Nextcloud sync target with Nextcloud.

Hi :slight_smile:

Thanks for all your answer :slight_smile:

I have found a solution to my problem. :slight_smile:

Instead of using "Nextcloud" in Joplin sync settings, I used "WebDav"

In the URL: I used this: https://my-site.dk/remote.php/dav/files/MY-NEXTCLOUD- USERNAME/Joplin

And logged in with my username and password from Nextcloud!

Rember to create a folder in nextcloud called Joplin

And now it works.

@Taxick, even though you solved your issue by switching to WebDAV, I propose a possible alternative solution for others that involves filesystem syncing, too.