Cannot setup sync because of "Unsupported WebDAV URL format"

I have issues to use my work’s NextCloud instance as sync service. The URL provided by NextCloud has the pattern and it works with other tools like, e.g., WinSCP.

If I change the /dav/ part to /webdav/ the URL is accepted, but it won’t connect. Can anybody help?

The Joplin API for Nextcloud is still a prototype so if it doesn’t work for you there’s not much to do at the moment, other than waiting for an update. Regular sync should work though.

Do you have a “dedicated” Joplin folder are are you syncing to the account root?


Apologies for my previous cryptic posting…

I have had previous discusssions on this forum about getting Joplin to sync with Nextcloud. You could possibly try these options:

  • Use the Joplin WebDav connector not the Nextcloud one.

  • Assuming you have a “Joplin” folder where you sync your notes try

If you sync to the root of the Nextcloud files storage, delete /Joplin at the end of the URL.

I have never tried this with a non-standard port so good luck.

It worked with WebDAV! thank you very much :slight_smile:


You are more than welcome.

Could I ask a favour? Could you please press the “Solution” button on my post? This means that anyone else browsing the forum with the same problem as you will see a “ticked box” against your question. They can then see that your problem had a solution. May save someone else a little bit of time!!