Unresolved Synchronization Error

Operating system


Joplin version


Desktop version info

Joplin 2.13.10 (prod, win32)

Client ID: 2a7576b949b04f8fa45d838d9d98a133
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 9731936

Agenda: 3.7.1
Bible Quote: 2.1.0
Calendar: 1.0.0-rc2
Favorites: 1.3.2
Jarvis: 0.7.0
Joplin DDDot: 0.2.0
OCR: 0.3.2
Random note: 1.0.3
ReMoods Theme: 4.6.1
To Google Search: 1.0.0
Toggle Editor Menu & Keyboard Shortcut: 1.0.1

Sync target



Markdown Editor

What issue do you have?

I am encountering the error "Some items cannot be synchronized." This error appeared out of nowhere, and despite attempting synchronization, it does not resolve. I have been grappling with this nonsensical situation for two days now! Two days ago, I used the "Re-upload local data to sync target" option in the synchronization settings. It re-uploaded all the data to the cloud. However, the error persists.

Previously, I experienced the same error in the mobile application on Android, and I had to uninstall and reinstall the application! I have nearly 2 GB of data, and re-downloading them is not easy; it takes at least 1-2 days. If you want us to switch to Joplin's paid server instead of using free servers, please let us know so that we don't waste our time in vain.

Joplin has a rich interface and great features, but it also leads to amateurish errors and time wastage. It's truly astonishing to be dealing with such a situation.

Because it's free and open source, and it has plugin support, I continue to use Joplin. But I really think it's time to congratulate Joplin developers on a job well done. Creating an application that is both beautiful and filled with such simple errors is not an easy task!


You are angry, that can happen. But before you post, please let steam off and post the next day. There are many possible reasons why that happened to you, and that it is Joplin's fault is possible, but is not the most likely.


You accuse me of being angry, but I'm not sure if you've read my message correctly. As a user, what responsibility do I have in the face of an error warning that cannot be resolved, closed, or intervened within the application? All I'm able to do is to synchronize the data again, try the "Re-upload local data to sync target" option, and finally, try the "Delete local data and re-download from sync target" option. But guess what changed? Nothing at all.

Update: I completely exited the application and restarted it. I have no idea if this has anything to do with it, but the error message disappeared.

You do come off as angry, with your final paragraph being a sarcastic insult to the devs who provide you work for free.

And then you follow up with the problem's gone away by just closing the app and opening it; something that would have been implicit on a system reboot, which is one of the singular most recommended and important troubleshooting steps that exists, did you jump to insulting the devs before turning it off and on again?

If you want people to help you, generally insulting them isn't the way to do it, are you going to take over the maintenace for free when the devs are burnt out from abuse?


I wrote the last paragraph not as irony but in its literal sense. I appreciate the efforts of the developers. If you read carefully, I am expressing that I really like the application, but despite that, I cannot comprehend how such simple and absurd errors occur.

I'm not sure if restarting the application has anything to do with the disappearance of the error message. Even if it does, it doesn't explain why I received the error, why I need to delete and reload the data. Wouldn't it be better to be enlightened by someone with technical knowledge rather than finding a solution through trial and error?

No one said you had to do that, you did it without asking. By doing so, we can't now explore what happens if you didn't do that, meaning that it's cut off entire avenues of "what-if's". People would have probably recommended trying safe-mode first, which also involves restarting the application!

Sure, assuming that anyone on the planet has that knowledge. Is the problem caused by one of your multiple plugins that aren't related to what the Joplin devs provide. Is it caused by an antivirus. Intermittent server errors (that again Joplin isn't providing), did a single bit error occur from cosmic radiation? Is your hard drive or RAM unreliable?

We might never know, and in most cases, being unable to help people actually sucks because you wish you could do better. But when the comments are like yours, at least we don't have to worry about feeling guilty for not being able to help.

I'm coming down stronger than I'd like, but hey, it's literally Christmas Eve, and as I sit here compiling Joplin for 3 hours on a Sunday in the holidays, which is less than 1% of the effort of what the actual maintainers do; popping in to see how things are getting on, my festive spirits are nicely popped from reading this, nevermind the people actually putting in daily effort for free.


If those questions were asked, I would answer them. But I had to find the solution again through trial and error!

If you don't feel guilty, then there's nothing to talk about. Goodbye!

1 Like

Here, the same error occurred in my Android application for no apparent reason. Just so you know...

I apologize for using a harsh language while experiencing the issue. I did not intend to hurt anyone. I want you to know that I really love the Joplin application and community, and I also recommend it on YouTube comments.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.