Sync problem today

Hey!
I love your app, and it’s the most important part of my day to make notes.
Since coronavirus im March I didn’t have any problems with syncing my notes throught DAV with pCloud.
It work on my Debian 10 Gnome, and Debian 10 Xfce4, and android f-droid.

Today I tried to update my day notes on Debian 10 gnome and I got this error:
“Last error: Error: Sync version of the target (2) does not match sync version supported by client (1). Please upgrade your client.”

So I checked the version in Help/Check for updates and was told there is a new version.
So I did: wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash
And installed the newest version
“You already have the latest version 1.0.233 installed.”

I also added “–no-sandbox” to exec line in:
~/.local/share/applications/appimagekit-joplin.desktop

and I can run the newest version of Joplin… but still got this message:
“Last error: Error: Sync version of the target (2) does not match sync version supported by client (1). Please upgrade your client.”

What do I do wrong?

All the best
Adam

Seems like one of your clients is a pre-release version and has upgraded the sync target. You can either update all your clients to the latest pre-release versions (apart from iOS and CLI which do not have packages yet) or clear everything down including your online storage and start again using just release versions.

Pre-releases

Posting Informing Users

Others reporting a similar problem

Thank you for your time and answer.
I am not sure if I understood.

Do you think my Android Client Joplin 1.0.337 Database v33
changed something on my data base in pCloud
and that’s why my Debian 10 Client 1.0.201
(now uploaded to Debian version to 1.0.233)
doesn’t work?
All because my Android Client?

Hmmm

I upgraded my clients on both Debians. And still error.

Forgive me if I don’t understand

A release version is considered as a stable version suitable for general use. This is then followed by one or more pre-release versions that users can use for beta-testing. Once that is done a newer release version is issued.

Using the Android client 1.0.337 (a pre-release version) has upgraded how Joplin stores your notes on pcloud. This means that any other client you use has to be able to understand that new format. None of the current release versions will understand the new format so you will have to upgrade your clients to a newer pre-release (beta) version.

If you use the Linux script to update your Debian boxes it will only check for newer stable release versions. That is why it will still not work. However @CalebJohn in one of the linked posts above mentions that using the flag --prerelease with the install script will tell the script to get the very latest version even if it is a pre-release (beta). At the moment that is v 1.0.235.

Thank you for your answer. Now I get it.

But how can it be, that my android app, installed and updated via f-droid, suddenly installed beta-testing relise that break my Stable releases on Debian?
I didn’t ask for any beta :-/

That does seem odd because I cannot find any version of Joplin on F-Droid.

I have two android phones. Joplin on phone-1 and Joplin on desktop can sync to my Nextcloud webdav. But joplin on phone-2 is unable to sync after I have uninstalled and resinstalled the app. The error message is Network request failed. But I am very sure that my configuration settings is correct. Any ideas what else can I try to solve this problem ? Thanks.

One thing to try is on phone-2 check the webdav URL starts https and not http.

Otherwise you could try searching this forum for “Network request failed” and see how others have dealt with it.

I don’t remember how I got Joplin on my f-droid, but I guess I added some Repositories.
As you can see - the latest/recommended version from f-droid is 1.0.337

Maybe I should just wait until the pre-release file format become release?
Because it is not comfortable for me to suddenly cleaning all my notes, exporting them somewhere, killing the app, and my directory on pcloud with encrypted notes, and again install one of good working client … :-/

I guess that whoever runs that F-Droid repository is taking the latest Joplin apk regardless of whether it is a beta or not. That's not helpful.

That will mean that you cannot sync Joplin from a desktop machine until a new release version is published.

I have tried the latest pre-release (1.0.235) on a test machine and nothing went obviously wrong. In fact, as this version has some bug-fixes I have been waiting for, I have been thinking of moving to the pre-release myself.

So if I were in your situation, as your sync target has already been updated and you are not keen on clearing everything and starting again, I would:

  • Make a JEX backup of my notes on a desktop machine (using File > Export > JEX - Joplin Export File)
  • Install the pre-release on the Debian machines (using the --prerelease flag)
  • Use Joplin
  • Make further JEX backups on a desktop machine if I have significantly updated any note(s)

That way you can continue to use and sync Joplin but you will also have a current backup if any critical bugs do happen to emerge.

So I found the solution.
Thank you dpoulton for your help!

  1. On my Debian 10 Fxce4 and Gnome I downloaded the script from the official joplinapp.org with this command:

wget - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh

  1. I added executive parameter to the script:

chmod +x ./Joplin_install_and_update.sh

  1. I run the script with “–prerelease” parameter:

./Joplin_install_and_update.sh --prerelease

  1. Joplin was working fine after that on my Debian 10 Xfce4. But on the Gnome I had to add “–no-sandbox” to exec line in:
    ~/.local/share/applications/appimagekit-joplin.desktop

And now the Syncro is working fine on all my devices (Linux, Android)!!!

There are few things that are on my mind:

  1. Why did my android f-droid updated Joplin to pre-release version (making sync problem with other release clients)

  2. Will I have to use pre-release versions on all my clients forever? I would rather use stable releases than have beta versions.

Oh! While I was writing the answer you already made a post with answers I was looking for.

Thank you so much for your time!

That’s really nice.

All the best

Adam

You can also install the prerelease Version with one command:

 wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash -s -- --prerelease

Niceeee! I didn’t know this one.
How does
“bash -s --”
work?

I mean what exactly does -s and –
?

I wish I could help you.
When I had problems with sync with DAV I wrote an email to support@pCloud (where I storage my encrypted notes).
They fixed it.

But I don't know how about your Nextcloud, never tried it :frowning:
Maybe the administrator of your server where Nextcloud is would know the answer?

I am sorry for not being helpful.

Maybe try to make your own topic on this forum?

Hi
Strange I downloaded the latest apk, Joplin 1.0.337 version (Android) from the Joplin GitHub, so not thru F-Droid, and now I get this error message in the desktop Joplin 1.0.233 (macOS) version:

Last error: Error: Sync version of the target (2) does not match sync version supported by client (1). Please upgrade your client.

But I am running on both machines the latest versions.

On Github:

This is the macOS download link:
https://github.com/laurent22/joplin/releases/download/v1.0.233/Joplin-1.0.233.dmg

This is the Android 64-bit apk download link: https://github.com/laurent22/joplin-android/releases/download/android-v1.0.337/joplin-v1.0.337.apk

The latest desktop Joplin 1.0.233 (macOS) version seams not compatible with the latest mobile Joplin 1.0.337 version (Android)?

1 Like

You, like the F-Droid repo, have downloaded from GitHub the Android Pre-release which upgrades the sync target and so requires matching pre-release versions of the desktop clients.

It seems however that the Android releases page does not have a warning like the Desktop releases page does.

Important: This pre-release will ask you to upgrade your sync target and, once it is done, only the latest clients will be able to sync with this sync target. Currently that includes the desktop app (v1.0.234+) and Android app (v1.0.337+). It means if you are using these two clients you’ll be fine. However if you are using the iOS or CLI clients you might want to wait till these clients are updated. Any issue with the sync target upgrade, please post on the forum.

1 Like

Then is the normal 64-bit APK download link changed from Latest Release to Pre-release, because there I download Joplin. And I have never had problems with that download link before.

@bartatgithub

The links on https://joplinapp.org are always links to a RELEASE version and not a pre-release version.