Sync version of the target does not match sync version supported by client

Environment

Joplin version: 10.0.52
Platform: iOS
OS specifics: 13.6.1

Steps to reproduce

  1. tap on sync on iOS app
  2. App says: sync version of the target (2) does not match sync version supported by client (1). Please upgrade your client.
  3. The macOS (10.15.6) app (1.0.237) has working sync, sync is on WebDAV

Describe what you expected to happen

Sync succeeds

Note: this has been put as an issue at github (https://github.com/laurent22/joplin/issues/3692#issue-690910616)

It would appear that you did not search the forum before posting this otherwise you would have seen several posts about “does not match sync version supported by client”. It also seems that you did not read the release notes before installing a pre-release version on your Mac. If you had you would see that 1.0.237 on your Mac has upgraded the sync folder type and so your iOS app can no longer connect.

IMPORTANT: This pre-release will ask you to upgrade your sync target and, once it is done, only the latest clients will be able to sync with this sync target. Currently that includes the desktop app (v1.0.234+) and Android app (v1.0.337+). It means if you are using these two clients you’ll be fine. However if you are using the iOS or CLI clients you might want to wait till these clients are updated. Any issue with the sync target upgrade, please post on the forum.
(My emphasis)

If you are wondering when an iOS client may be released, there have been posts on the forum about that as well.

Sorry I was not aware I would be installing a pre-release since I am just following the stables on homebrew for macOS. I would clearly not expect that pre-releases are making their way into the regular stable homebrew. Not sure how this happened, but it is not ideal.

We don’t control the homebrew release, and it seems they’ve been using pre-releases and distributing them as regular releases. I’ve left them a message so hopefully they’ll change their script to prevent this.

@laurent

It now looks like F-Droid, Homebrew and AUR maintainers are including pre-release versions so users are getting caught out rather than ignoring the release notes.

EDIT: Just noticed on the GitHub post (linked above) that you are aware of this…

EDIT2: Github post linked above now clarifies that it was not AUR (which uses release packages only) but Homebrew.

It is now clear that homebrew is providing pre-releases rather than just full releases, so I apologise for suggesting that you did not read the release notes.

Yes for the record I’ve put here the list of the main distribution channels. It seems only the Chocolatey one is doing the right thing but I’ve contacted the maintainer anyway.

@laurent

Whilst there have been posts about the new sync target upgrade causing problems by behaving exactly as the release notes said it would, there do not appear to be any posts highlighting problems with the upgrade itself. Is this upgrade likely to reach a full release soon?

Yes there was one big issue which has just been solved, and the rest I’ll probably look at them soon and release all versions.

2 Likes

That are good news.
In the meanwhile homebrew have rolled back to 10.0.233 which will overwrite 10.0.237 on many systems now automatically. Many of those people already have probably upgraded their data format!

I am experiencing what that means now. The old stable will not run with the upgraded data!
So now I have NO working Joplin.
On macOS it will not start because data was already upgraded.
On iOS it will not sync because the data was already upgraded.

What should people do who are now stuck in this situation?
How can data be rolled back to the old format?

I understand that you guys are now in a corner although you were very transparent about this. (I am the last to point at you guys. From my perspective Homebrew should just not have pushed a pre release to the stable branch.) In the end this is not about whose fault it is that many users are now stuck without working Joplin, now the key is to help them to get of this situation to be able to work again. Homebrew tried to fix this, but again, that creates problems. I think the Joplin team are the only ones who really can help to mitigate the situation effectively.

I agree it’s a mess because this release kind of uncovered various distribution channels we weren’t aware of, or if we knew about them we didn’t realise they were using pre-releases. All maintainers have been notified now and they’ve updated their scripts so that it doesn’t happen again, so at least future updates should be better.

For the current one however there’s no easy fix other than releasing the new version officially for all platforms. Thankfully it’s nearly there - all bugs are fixed and there’s just one small update to make on the mobile app. I’m hoping that can all be ready by tomorrow and I’ll release all versions at that time.

1 Like

Yeah, crap situation. You guys create free stuff thats awesome and you get into trouble for that together with many users.

Keep up the spirit

OK, today macOS and iOS stable releases arrived and work together again. Back on track and great work of team Joplin!

Please excuse me incompetence. I am still having this problem with Ubunto. How can I fix this?