Home / GitHub Page

It works separately but it doesn't work to synchronize

Hi,

I use Joplin on my mobile device and my desktop through dropbox.
Unfortunately, the notes/books are not the same.
Separate synchronizations work but as of result, this is not the same on the devices.

Iphone:10.0.37
Desktop Win10: 10.0.170

Thank you

up

Are you sure both devices sync to the same Dropbox account? Check the sync status on each and check the files on Dropbox under the App/Joplin folder, Are all files from each device in the folder on Dropbox? are any errors showing in the sync status logs?

I removed the content of App/Joplin and removed the Joplin rights then.
I started from scratch and despite the loss of a lot of things it works now, thanks.

@mulanee I’m glad it’s working, but sorry to hear you lost a lot. Did you export your data to JEX files prior to removing it? When you “removed” Joplin, did you delete the files/folders, or rename them? Is there any chance the data could be in the trash bin?

I’m having a similar issue. Sync doesn’t actually sync. I believe that in my case, it is an issue with Catalina.

I have created a new note in Joplin on the desktop (running Mac OS 10.15.1). Then I click the Synchronise button.

Completed: 11/11/2019 15:13

Last error: FetchError: request to https://api.dropboxapi.com/2/files/create_folder_v2 failed, reason: self signed certificate in certificate chain

I believe that the “self signed certificate” is the issue.

I also created a note on an iPhone (running 13.2.2). That note seems to have sync correctly (it appears to be in Dropbox). However, it is not showing up on the Mac.

Devices:
Mac (running 15.10.1)
iPhone (running 13.2.2)
Dropbox for sync
Joplin 1.0.160 (prod, darwin)

There is an update to Joplin (verion 1.0.173). I’ve installed that one. I did get the notice about not being able to open the App as Apple can’t verify the developer.

Unfortunately, still no sync. Same failed reason: self signed certificate in certificate chain.

How can you have a self signed cert when you connect to Dropbox? This sounds like a MITM attack.

I didn’t export anything because I was not able to find the way on my mobile phone.
I deleted the folder and the application on the dropbox web interface.
This is done it works, that’s the most important I rebuilt the deleted files easily.
Thank you for the support

Pretty much correct. Deep Packet Inspection was turned on at work. We had to exempt Dropbox.

This is old so I assume you got it working. If not, the next question is did you enable encryption? If so, since Dropbox is blocked, I would suggest exporting your data, delete everything including the folder on Dropbox, and starting over from your home computer.
If you did not encrypt, you could set it up at home without deleting anything. It should sync properly with your phone. In which case it’s the Dropbox filtering at work that’s blocking, which we both know to be the case anyway, This is simply a verification.
Are any other file sharing services allowed, such as Box? You could set Joplin to sync anywhere. You could also create your own host on a home computer to sync.

Use, I got it working. Thanks for the follow up though.

(Basically, we had turned on Deep Packet Inspection. I had to exempt Dropbox for me in order for it to work- essentially, we are running a MITM on our network).