Sync issue

Hello, I have the same problem, except I am using Android and Windows. Reinstalling the app and resyncing on the phone did not download all my notes, just some of them, and they are not even sorted in the correct categories.

Update: I tried exporting a JEX file from my other phone, which has all my files, and importing the JEX file on my computer (Windows 11). Here is what many notes look like (all the question marks are supposed to be Chinese characters) On the bright side, at least it looks like all my notes are there, and in the right categories/notebooks:

You say "I have the same problem", .... which one ?
You said exported from "my other phone" .... which OS, and how did you do this (exporting is not supported on phones (Android or iOS) ? manually ?

... because this is how it went wrong, I suspect.

1 Like

Downloading the Joplin app on my new Laptop with Windows 11 and syncing with Joplin cloud does not download all my notes, and even those that are downloaded are not categorized in their correct notebooks. This same problem happens when I sync on a newly downloaded Joplin app on my Android phone.

I can export my notes as a JEX file on my Volla OS phone, but if what you mean is that it does not work properly, that would explain the ? symbols.

The other person in the original thread said he fixed it by downloading the test flight version, but that seems to be available only for iOS. Do you know how to solve my problem?

on what system (OS) were the notes originally created ?
from what system(OS) were the same notes originally sync ... to what target ?
does this system still sync without errors (see log) ?
when you export the notes are there any errors ?
before you tried to import the notes into Joplin on win11 -> did you first completely uninstall the Joplin version AND delete the profile folder ?
Reading your two notes I have the feeling you had problems on both devices. In which case I don't think I can help.

The notes were first made on my Windows 10 laptop. I edited them both there and on my Volla OS phone. They were originally synced to a local folder, before I bought a subscription for Joplin Cloud this year.

My Windows 10 laptop is broken and can no longer be used, so I cannot test using it. I can try reinstalling Joplin again after deleting the profile folder. Where is it located?

  • while the last Joplin on win11 is still installed : goto menu -> help -> open profile folder
  • go up one folder, from there remove the whole folder called Joplin
  • now remove / uninstall Joplin
    (I am staying a little vague here because I don't use windows)
  • download the latest version of Joplin for win
  • go offline
  • install Joplin
  • setup sync (exactly what you did long ago under win10)
  • go online and sync
    ... now pray :wink:

The ? symbols are likely related to this issue with JEX exports on Android:

It's fixed in the latest pre-release, which can be downloaded from GitHub (at Tags · laurent22/joplin-android · GitHub) or from an unofficial FDroid package.

There should also be an option to "export profile" on the Android device. This can (I think) be used as a backup (should updating Joplin on the phone fail).

Thanks, I did as you said and I have all my notes again. I did not pray before I tried, but I did after it worked, and gave thanks to God.

Alright, thanks for letting me know.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.