Sudden problem with how text appears

Operating system

Android

Joplin version

2.14.9

Editor

Markdown Editor

What issue do you have?

Hi!

I've been using Joplin for a while and suddenly my text appears differently in all my notes. Everywhere I have used an 'enter' to go to the next line, it suddenly shows everything in a row. So for example: if I've made a list that looks like this
Bread
Milk
Sugar
Tea

Suddenly the note will show
Bread Milk Sugar Tea

It just puts everything on a long line. But when I go to edit the note, it shows as
Bread
Milk
Sugar
Tea

And then when I leave the editing it shows wrong again.

This never happened before and I don't know what to do. It makes things unreadable and I really like my lists so a lot of my notes are like this now.

I added a screenshot with on the left the note in edit mode, and on the right the screenshot shows the same note in read mode. (I was not allowed to add two screenshots so had to get a bit creative here).

I hope somebody can help me out!

Screenshots

This might be related to the "soft breaks" setting in Configuration > Markdown > Enable soft breaks. See also soft breaks in the commonmark spec.

2 Likes

Yes thank you that solved it! I'm very happy now haha

@naatjess welcome to the forum.

Your comment about having to be creative with the screenshot made we wonder if you were confusing the Rich-Text Editor with the Markdown Editor viewer. In the Markdown editor you can capture the Markdown and also how it looks when rendered in one screenshot.

To explain:

Joplin has two editors that users can use for note-taking.

The icon shown by the arrow below is for the Rich-Text Editor. This is an all-in-one WYSIWYG editor for your notes.

image

The other button (in the red square below) is the Markdown Editor. The arrow points at the Toggle Editor Layout button which changes the layout. Each time you press it it will cycle between editor only, split view and viewer only.

image

If you do not want to cycle between all three views when you press the Toggle Editor Layout button, the sequence can be controlled using View > Layout button sequence.

So when choosing split view the one Markdown editor window should be split into two panes, side by side, one showing the Markdown you are editing and the other how it looks when rendered.

1 Like

Thank you I will definitely remember that!