Home / GitHub Page

Spaced repetition plugin

Hi!

I was wandering if it is possible to build an plugin for spaced repetition of notes in the way that Anki works. I know there is a reminder feature in Joplin, but its not quite ment for the same function.

It may be so that Joplin is not build for this. I’m asking since I’m not a fan of Anki’s propetary server. There is no way to sync it with your own server. Also, Joplin seems to be able to do much more.

Is this something someone else than me is interested in? This spaced repetition thing has totally changed my life and I can recommend it to anyone who haven’t tried it.

It’s certainly an interesting idea! I could definitely see some future where Joplin has plugins that allow for that sort of thing (I’m not a dev so take that with a grain of salt). That said, implementing a flash card system is a pretty far stretch for a notetaking app, so I would guess that this isn’t likely to come about soon.

There have been similar requests before notably this one where [@foxmax links to a tool they developed that integrates Joplin and anki.

1 Like

Thanks for the response!

It indeed seems like a nice tool, but for what I see it imports from an specific note. But since he has already done much of the work I could maybe extend it if I have time.

I use it for more complex topics which needs more descriptions than an explanation of an word and sentence. Maybe I could just create an export from notes to anki? I.e. that each notebook is a Deck in anki, and each note is a flashcard?

One alternative is to have each markdown title size 1 to be a flashcard in anki. What do you think?

This may be unrelated, but is it possible to have another level of depth in the notes?

Export from Joplin to Anki is already done! Take a look at the link I sent you, it should have everything you need.

I don’t really understand what you mean by depth.

Sorry, it was just to drag and drop a notebook into another notebook. Nice! That was what I wanted.

I’ve tried the tool, but get a lot of errors. It seems to be quite buggy and the instructions are unclear. I guess I contact the developer.