Home / GitHub Page

[SOLVED] Encryption Sync Issues

Hi,

First of all, Joplin really looks promising as an substitute for OneNote, Evernote, a.s.o. Thanks for that.

I installed it on Windows 10 and an Android smartphone and tablet. I activated sync via OneDrive. Worked perfectly!

Then I switched on encryption on Windows 10 and sync’d. Did the same on my phone using the exact same password (and tested 3 times with even deinstalling Joplin). Result: My phone can’t decrypt the files from OneDrive (coming from Windows 10).

Am I doing something wrong or is this a usage scenario that is not planned/implemented?

Thanks for any answer that sheds some light on my issue.

Best regards,
tom

1 Like

What does that look like?
On my phone, it took a long time to sync. Then I saw just ‘encrypted’ for a reeeeallly long time, because the decryption went slowly. When I just let it lie for a few hours, it got around to decrypting everything eventually. (I had the exact same setup as you describe: from win 10 to android via OneDrive. Haven’t tried tablet and have since switched to NextCloud, but that should not be relevant now.)

1 Like

Hi zblesk,

Thanks for your feedback.

Well, did not wait for hours right now. Just have one note at now. But I will wait for 24 hours and then report back here.

Regards,
tom

Well, that’s bad - if you only have one note, it shouldn’t take that long I think. :frowning:

Also keep in mind that you need to wait for the master key to be downloaded before decryption starts. That key can arrive at any random time during sync so indeed you need to wait for the full sync to be sure.

If there’s just one note though there’s most likely a problem and you’ll need to check the log.

Hi Laurent,

I checked the GUIs (Win10 and Android). Unfortunately, I could not find any entry that looks like a log file. Could you tell me where I will find these log files?

Thanks in advance.

Kind regards,
tom

Please have a look at this page to enable debugging/logging: https://github.com/laurent22/joplin/blob/master/readme/debugging.md

If you could post a log with the errors or warnings it should be possible to help.

Hi,

Thanks to all that supported me having this issue. I finally managed to solve it. I will note down the steps taken so someone facing the same problems will find, at least, my solution.

I conducted the following steps:

  1. Deleting Joplin on all my devices: Win10 laptop (A), Android OnePlus 5 (B), Android tablet (C )
  2. Deleting all Joplin entries on OneDrive
  3. Deleting all Joplin entries on A (can’t find the data on B and C)
  4. Installing Joplin on A
  5. Activating OneDrive sync on A
  6. Configuring encryption on A
  7. Add a notebook and one note on A
  8. Trigger manual sync on A
  9. Installing Joplin on device B
  10. Configure OneDrive sync on B
  11. Manual sync on B. When being asked for a password I entered the same as on device A.
  12. Repeated steps 9 through 11 for device C.

Works for me. Now I will have a closer look at Joplin itself. Prolly will come up with some new questions.

Thanks and regards,
tom

2 Likes

Marked my post as [SOLVED],

I found the issue to be, if syncing to Dropbox or Onedrive, you may probably want to select the attachments to be download “ALWAYS”.
I waited for several hours and before deciding to erase them all and start from scratch,
I changed the attachment download behaviour to Always.
Then the master key came in.

Sigh, so apparently the encryption master keys are counted as attachments too.

@laurent is this true? Is there a way to retrieve the master keys separately?

No, for sure the attachment download behaviour doesn’t affect the master keys. They are always downloaded. So it was a different issue but not sure what.

Thanks for the info. Just wanted to make sure.

FWIW, I was having problems syncing encrypted notes as well. Changing the attachment behavior from auto to always solved the problem for me as well.