I tried to update to 1.0.193 encryption and synchro

Yesterday, I tried to update 1.0.193. My environment is composed two windows 10(1909), 2 linux(arch,centos), two smartphones(android private/professional). I have more 400 notes. On Onedrive

I downloaded it from github. On windows and linux, I didn’t have any problem but on android I had an issue with the encryption. I read the release note, and I saw the encryption has been updated so I checked android version (1.0.322). I think it should be ok.
That doesn’t matter, I decided to re-install / re-sychronize. So, I made a backup (export jex files) , clean the different folders, re-install and import my notes on joplin.

  1. Linunx/windows I Deleted local repository /user/.config/Joplin-desktop
  2. Android in “application setting” I cleared data and cache. And finally uninstall.
  3. Onedrive I deleted appl/Joplin and I recycled the garbage


  1. On windows, I imported my notes from backup.jex file. OK
  2. I configured encryption, OK
  3. I configure onedrive ok
  4. I synchronized Joplin with OneDrive, Ko- the synchronization stops all time after one dozen notes with a message “create remotes items 14: completed …”. and not everything at once without stopping the synchro?
  5. When I tried to synchronize with the other devices, Android and windows has not able to decrypt the notes. The application didn’t ask me the password for new key.
    Thank you for helping me solve that problem.

Note : I think there are a bug in “notes importation”.
For example, if I have the same folder name with a different parent. Joplin adds a suffix to the folder name like “(1)”

folder_A->sub1, folder_B->sub1, => export => import=> folder_A->sub1, folder_B->sub1 (1),

With android seems ok. But not with windows and linux.
I saw a timeout dispite I’m on the same network

I tried the direct link(copy and past, the link from log file) on win/linux. I’m able to download it with chrome.

https://public.dm.files.1drv.com/y4m3Fe31uUUAEotkDaMJcWhhgj5fziW3EczfpbhEwQOy-1Ckab6AiPl2s1cQDvX7i0J8K-sqvdVsKCiylmSKVKN_rMnAWBALzpwqeDIvpSZB_iba9wx8zCOZLtFlXmnrpR1PDQpUTR-67dBNhd45AtZieqyVRA89P8IaCDw-nIzKgklJKutnyl2v58tP2m6Nla7GzDluV_BICwtg-htwllAl1HtKZtJ0jCiN7uL1JCMDyg/2ea5a47a8cbe42288be798b056841c7e.md failed, reason: connect ETIMEDOUT", "FetchError: request to https://public.dm.files.1drv.com/y4m3Fe31uUUAEotkDaMJcWhhgj5fziW3EczfpbhEwQOy-1Ckab6AiPl2s1cQDvX7i0J8K-sqvdVsKCiylmSKVKN_rMnAWBALzpwqeDIvpSZB_iba9wx8zCOZLtFlXmnrpR1PDQpUTR-67dBNhd45AtZieqyVRA89P8IaCDw-nIzKgklJKutnyl2v58tP2m6Nla7GzDluV_BICwtg-htwllAl1HtKZtJ0jCiN7uL1JCMDyg/2ea5a47a8cbe42288be798b056841c7e.md

Does anything from here help?

I moved on Dropbox and it’s ok… It s strange because previous works well and the latest version on Android are Ok with onedrive. So for me, it is not good news. Dropbox is blocked in my company…
Please could you fix that as soon as possible?

Thanks but doesn’t Help me

1 Like

No worries. I hope your issue gets resolved and someone can help you get it figured out.