Deliver me from encryption hell!

I have installed Joplin on 4 different platforms in hope of synchronizing between them via Dropbox.
In order of installation, they are:

  • Joplin app v12.7.1 on iPadOS 15.3.1
  • Joplin app v2.7.2 on Android 12
  • Joplin Desktop v2.7.13 on Windows 10 21H2
  • Joplin Desktop v2.7.13 on Ubuntu 18.04

I have successfully authorized all 4 installations to use my Dropbox account.
As far as I can reconstruct, 3 of the 4 installations were installed with encryption enabled by default. Only the Ubuntu installation did not have encryption enabled on first run. I am not aware of having enabled encryption nor do I recall being prompted for a password.
I first noticed the encryption when I tried to synchronize notes between my smartphone and my iPad.
I therefore turned off encryption on both.
As a result the smartphone said it was resynchronizing everything without encryption, but this is not true.
I now have:

On Dropbox: 49 md files in the Apps/Joplin root directory, none legible.

On the smartphone:

  • the Joplin Welcome notebook containing 5 notes
  • two additional notebooks containing a total of 3 notes

On the iPad:

  • banner "Please set the decryption password"
  • 2 copies of the Welcome notebook containing 5 notes each
  • 3 "Encrypted" notebooks with a total of 8 "Encrypted" notes
  • a "Conflicts" notebook containing 2 of the notes I created and copies of the 5 Welcome notes

On Windows:

  • banner "One or more master keys need a password"
  • 2 copies of the Welcome notebook containing 5 notes each
  • 3 "Encrypted" notebooks with a total of 8 "Encrypted" notes

On Ubuntu:

  • banner "One or more master keys need a password"
  • 2 copies of the Welcome notebook containing 5 notes each
  • 3 "Encrypted" notebooks with a total of 8 "Encrypted" notes

How can I get this to work as expected, i.e.
All files decrypted and synchronized on all devices?

E2EE is not enabled by default, and wouldn't work unless you created a master key.

The advice is to start by enabling this on one device first, i.e., a desktop. Likewise, reversing the process should be done in the same way. So, starting with one desktop only, disable EE2E, and once this is completed, export your notes as a precaution. Then follow through with the other devices one at a time.

If this isn't possible because you've not set the master key on those devices (and don't remember it), start with your phone, since this doesn't require a password. If possible, share a screenshot of the Encryption Config page.

Thanks for the quick response!
I have already disabled encryption on all 4 devices. Here is a smartphone screenshot.
Thanks for your support!

1 Like

Okay, so you’re all good now?

Not at all!
The results of these operations are described in detail in my post.
I can read 3 notes on my phone but nothing anywhere else.
Thanks again.

You need to work one device at time - sync the device with all the notes, make sure they are all synced. Then sync a second device. If notes are missing, check the log. How to enable debugging | Joplin

The only device which shows any human-readable notes is my phone.
It only shows 3 notes: I doubt that this is everything, but fortunately, I am just starting and do not have much content yet. The link you recommend refers to instructions for Android, but they appear to be out of date. There is no "Take bug report." in the Developer options of my phone. Nonetheless, I have managed to take a bug report, but I am loathe to post it publicly. Furthermore, considering how little I have already consigned to Joplin, it might be easier to start from scratch than to try to troubleshoot all 4 installations. How can I do this? Can I just delete the entire content of the Dropbox Apps/Joplin directory?

I don't think you need to start over. Just setup one device as you want, with it without encryption, and just make sure it's the device that has all the notes, then sync.

Then switch to the other devices and sync again. If notes are not showing up we need to see the logs. You can easily get it in Android and desktop at least, and you can just post the errors if you want.

The problem is not that notes are missing. If anything, there are too many. The problem is that most of them are encrypted. After syncing all devices without errors, the situation is still the same as in my original post. I don't have time for all of this troubleshooting. Please tell me the quickest way to reset all Joplin data to zero.
P.S. I tried to message you a link to an Android debug log, but couldn't figure out how. On my Messages page under new, it says, "Need to have a direct personal conversation with someone, outside the normal conversational flow? Message them by selecting their avatar and using the message button." However, I do not see a message button when I select your avatar or even when I go to your page.

Since Dropbox keeps deleted files, I went ahead and deleted the contents of my Dropbox Joplin folder. This had the desired effect of emptying Joplin on all devices, and notebook and notes are now synchronizing over all 4 platforms.
However, the banners reported in my original post remain:

  1. On the iPad: "Please set the decryption password"
  2. On Windows & Ubuntu: "One or more master keys need a password"

The first makes no sense, since no device has encryption enabled.
I have found several threads complaining about the second, but no solution.
How can I get rid of the banners?

A password occurred to me that I must have given at some point, so I entered it on all 3 platforms with orange banners. Now the banners are gone. All is well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.