Home / GitHub Page

[Solved] Encryption: some notes NOT decrypted

This happens to me in the Linux desktop Appimage: V1.0.179 as well as 1.0.193

Encryption is enabled (quite a while ago) and worked so far on the Linux desktop Appimage and on two Android devices.
Now one note (which was edited a few days ago on one of the Android devices) in the Linux desktop Appimage shows up as Encrypted (and a key symbol) in the list of notes. No content of this note is displayed. It is still listed in the mobile app (and can be edited there).
Encryption setup still looks good on all devices.

Any help/suggestion how to decrypt this note?

1 Like

If you go in the Sync Status screen is there any message about items that couldn’t be decrypted?

1 Like

I had the same problem: “Excrypted”.
Opening the Sync Status screen and clicking “Try again” did the trick
Thanks

1 Like

There was a message similar like “… one note couldn’t be decrypted because it is too large or broken”. After trying again (like suggested in the sync status screen) this note shows up and looks OK.
Problem solved!

1 Like

had the exact same issue, can’t believe i didn’t check the sync status page. fixed my issues.

thanks for joplin! :heart:

Hi, I had the same issue! Solution work as well for me :+1:

Hi!

I had the same issue on windows app and linux terminal node.js app.

However, the solution provided here only worked in the windows app, as I couldn’t find where to issue the “retry” command in the terminal app. Running e2ee status only says that I have encryption enabled.

Am I missing something?

Thanks!

Renato.

Hi, I have the same problem.

Sync Status shows items which couldn’t be decrypted. ‘Trying again’ results in a changed list of items. However, new items appear. In addition they switch between ‘Note’ and ‘Revision’. Furthermore, hitting ‘Trying again’ several times first shortens the list of items and then the amount of items listed increases again.
Is there any solution/work around?

Hi, same here.

Linux and Android versions worked well before.
Now, for some reason, the desktop app can’t decrypt new notes created with the android version. Vice versa it works just fine.

Pressing retry in Synchronization Status does NOT solve the problem. Behavior just as FreeCutter describes.

Please help. It’s a critical problem for me.

Thanks

1 Like

I can’t confirm this:
Created an encrypted note on the Android app and read it decrypted after the first sync run on the Linux desktop application (V1.0.193, Appimage).

Same issue here; notes recently created/edited on Mac or Android aren’t decrypting, and retrying just shuffles the list of failed decryptions.

It did successfully decrypt a new Notebook’s title though. :man_shrugging:

Updating to version 1.0.193 did the trick.
Seems backward compatibility is not given when updating only android.

Thanks

Confirmed, an update to 1.0.193 (and then doing through the Synchronization Status dialog) did the trick. I’d forgotten I had to update Joplin by hand. :stuck_out_tongue:

I had the same problem as described, sync / encryption from Ubuntu PC to Android working, but from Android to Ubuntu not.

Also solved by updating the desktop version (to 1.0.193) and going through the sync status dialog.

This calls for a feature request: create a .deb installation so software center will take care of updates and / or an integrated check in Joplin for available updates on startup.

Thanks to your posts, I was able to solve it: manual updating of my both desktop versions (Linux and Win10) helped; iOS is updating automatically :wink:
And: after updating going to Sync Status and checking ‘Try again’ cleared all items.

Joplin working across all most common OS is the big deal - Thanx!!!

Had the same issue, between 2 Win10 computers (one with v1.0.179 and one with v1.0.193) and 2 Android devices (v1.0.322).
Checking the Synchronisation Status tab on Win10, and retrying did not alone solved the issue.
After upgrading the Win10 instance to v1.0.193, the ‘retry’ option solved the issue.

Does the gap between versions cause the issue ?

1 Like

Yes, the encryption algorithm was updated with those versions, so of one client updates first, the older clients would be unable to sync.

My Joplin on win10 is at 1.0.193 already but sync to android is still not working and notes appear as encrypted.