Desktop app can't decrypt notes after edited by Android App

First of all, amazing job! Joplin is awesome.

I just have an issue with encryption (not sure if its a new issue or was there from the beginning). When I edit a note at the Android app and sync the desktop app just shows “Encrypted” instead of the page title.

And the sync status page reports:

So I started fresh but still the same. Here is what I did to retry:

  1. Took a JEX backup from all notes
  2. Deleting ~/.config/Joplin and ~/.config/joplin-desktop folders on my desktop
  3. Started the app
  4. Deleted the existing template notes and authorized Dropbox for sync and synced
  5. Setup the encryption and synced again
  6. Imported the JEX file of my notes
  7. Synced, everything was OK
  8. Cleared my Android app data/cache so that it’s fresh
  9. Authorized with Dropbox and synced
  10. It asked for the e2ee password and I used the one setup for desktop
  11. Synced succesfully everything ok
  12. Created a new note on desktop
  13. Edited on android app and saved/synced
  14. The note title changed to “Encrypted” on the desktop app after sync

Is it a bug or am I missing something?

Anything in the log?

Oh sorry I didn’t look at ~/.config/joplin-desktop/log.txt:

Error: Unknown decryption method: 5
    at EncryptionService.decrypt (/tmp/.mount_Joplin9sfbaf/resources/app/lib/services/EncryptionService.js:363:52)
    at EncryptionService.decryptAbstract_ (/tmp/.mount_Joplin9sfbaf/resources/app/lib/services/EncryptionService.js:431:33)
    at processTicksAndRejections (internal/process/task_queues.js:85:5)
    at async EncryptionService.decryptString (/tmp/.mount_Joplin9sfbaf/resources/app/lib/services/EncryptionService.js:496:3)
    at async Function.decrypt (/tmp/.mount_Joplin9sfbaf/resources/app/lib/models/BaseItem.js:366:21)
    at async DecryptionWorker.start (/tmp/.mount_Joplin9sfbaf/resources/app/lib/services/DecryptionWorker.js:169:29)", "{"id":"...a6db74","parent_id":"","item_type":0,"item_id":"","item_updated_time":0,"title_diff":"","body_diff":"","metadata_diff":"", ...CONTENT_REMOVED...,"encryption_applied":1,"updated_time":1586305146827,"created_time":1586305199570,"type_":13}"

And found this

Just FYI my version is slightly different:

Joplin 1.0.179 (prod, linux)
Sync Version: 1
Revision: 66356d8

Android app version: 1.0.324

Those 2 versions are not compatible (when it comes to encryption).

You have to upgrade your Linux desktop app to the latest version.

1 Like

Sorry, my bad :frowning: Upgrade solved the issue

Thanks for your great support!

No worries, all good. Glad it works now.

I'm having a similar problem - notes generated or edited on my Android device aren't decrypted on my desktop. I suspect it's related to a similar mismatch in the Desktop and Android versions that I'm using. Could anyone clarify? My version details:

  • Desktop Version: 2.6.10
  • Android Version: 2.11.31
  • Sync: Joplin Cloud

The latest desktop app version is 2.11.11. Make sure to update!

I updated the Desktop version and that fixed the problem. I also had to manually ask Joplin desktop to retry decrypting notes that had failed decryption :slightly_smiling_face: