[resolved!] The font change function of JoplinPortable does not work in Japanese environment

Resolved from a related post before posting :laughing:

When I tried to post it, I referred to the related post that showed up and it resolved the issue. Since I took the time to write it, I'll post it for others.
Userstyle.css does not seem to work in Windows 10 - Support - Joplin Forum


β†’ Quit Joplin completely and then restart it.
I thought I had restarted Joplin, but didn't realize it was stored in the tray icon. After right-clicking and quitting it completely, I restarted it and the font reflected no problem.



I tried to change the font of JoplinPortable in Japanese environment, but it didn't apply.


OS: Windows 10
Software: JoplinPotable v1.0.233
Language: Japanese

I tried.

Custom stylesheet for rendered Markdown

Edit to

/* For styling the rendered Markdown */ p, ol, li, ul, body, th, td { font-family: "UD デジタル 教科書体 NP-R", Georgia, Arial, sans-serif, "Source Han Code JP"; font-size: 15pt; }

β†’It's not reflected in the render view; restarting Joplin didn't help.

Font Families in Editor.

Specify the following font families
'SourceHanCode-Regular', monospace

β†’I tried restarting Joplin, but it didn't work.

Possible things.

  • Because of the Japanese language environment? |As is well known, Asian languages are special in that they are double-byte characters.
  • Because it's a portable version? | It's conceivable, but not enough to go through the hassle of building it again since it can be used with the default font.乁(ツ)ㄏ
    But I used to use a custom font in Evernote, so I'd like to recreate the same environment if possible.



Glad to see you were able to solve this! It is in unfortunate quirk of Joplin that I hope will be eventually changed.