I Can't Change The Editor Font

I’m using the Windows version of Joplin and I can’t seem to change the font. In the “Editor font family” space, I put the name of the monospace font I want to use but nothing happens, the font does not change. I tried closing and restarting Joplin but that didn’t help. Any info would be appreciated.

What I’ve found is that “Font family” is a misnomer. It implies a CSS family of multiple font names, but you can only add one.

Enter the font name without quotes, click OK, and the change should take place immediately. I’m on Windows, and have successfully used these fonts a few minutes ago.

Courier New
Fira Code
Space Mono

The latter two are not system fonts, but installed separately. It doesn’t look like the font names must exactly match case, but I’d still do so especially on Linux/Mac.

Hope this helps.

Thanks very much, that worked. Also, I really like Fira Code so thanks for that too.

You’re welcome. Fira Code is especially good for software development UIs that support ligatures, such as Visual Studio Code. But it looks nice on its own, too.