Home / GitHub Page

Korean input on Windows 10

I’m using Joplin 1.0.195 on Windows 10 Pro 64 bit

When I type Korean in the Joplin, the Note Editor in Markdown seems to display weird characters for spacing that disappear once space bar is pressed.

Here are some pictures of the issue:

Joplin_HsTKxt9CgN2

This seems to only happen on the Markdown editor area, but not on search or the Note title window.

I don’t know if this is a bug or I just have something set wrong, and this is entirely possible because I’m new to Joplin, but any help with resolution would be appreciated. Joplin is great, but the thing is pretty annoying.

Thanks in advance for your help!

Is it the same as this issue? https://github.com/laurent22/joplin/issues/1210

Sadly it doesn’t look like there has been a resolution on this yet. Because you’re on version 1.0.195, can you try the WYSIWYG editor and let me know if this issue still happens there?

Yeah. It’s the same issue.
It doesn’t do it on wysiwyg. That’s a good work-around for now but it’d be nice to use markdown at some point.
thanks!

Hi,
I somehow managed to work around the issue and wrote a bit about it, though it’s definitely a dirty workaround.

Yes, I totally agree with you.
Joplin is a great application and I love it so much, but this issue had been really annoying until I came up with the workaround. Now I’m pretty happy with it.

Hope this helps.

2 Likes

This isn’t the only issue we’ve had with the current editor. There’s currently a GSOC project slot that we’re hoping to fill that will address this issue.

1 Like

That is a great solution, not a dirty workaround.

I downloaded and installed the special font from your github link on Windows 10. It sits in the Fonts folder in the windows directory.
This might be a dumb question, but I can’t seem to be able to change the Editor font family in settings. Other fonts can be switched to by typing the font name in the field, but Joplin won’t switch to NoLSEP for some reason. Is there another step involved?

As the NoLSEP font has no visible glyphs (it has only a single, invisible glyph for the LSEP character), you wouldn’t see any changes in appearance.
It will just keep the weird “L SEP” characters from showing up while the editor text is shown with the default monospace font.

Do you still see the weird characters even after you set NoLSEP in the “Editor font family” field?

I don’t think the difference in language affects this behavior but I’m not completely sure.

If you have installed the font on your system, it would be enough to just specify its name in the “Editor font family”.

If the font is not installed on the system, you have to use “Custom stylesheet for Joplin-wide app styles”, which now seems to be hidden under the “Show Advanced Settings” by default.
It’s also true when you want to use a non-default editor font.

Any questions are welcome.

Thanks for your assistance!
I think I have the NoLSEP font installed correctly, but I’m unfortunately seeing the wierd character still. It might be a difference between languages I guess.

Thank you for trying out my workaround.
And I’m sorry it doesn’t work.

If you have a little more time to spare, could you try another method using the custom stylesheet?
It should work regardless of whether the font is installed or not.

For the language difference, I will look into it later.

Thank you for helping. The solution was elegant.

I tried the css style sheet - it didn’t work for me but I might have done it wrong - screenshots are posted below.

Thanks again for your help!

Your configuration looks good.
Let me just confirm one thing. Did you restart Joplin after saving the stylesheet?
I forgot to mention this in my blog post but it is on the official page.

Joplin: Custom CSS
https://github.com/laurent22/joplin#custom-css

If it still doesn’t work, please check once more if NoLSEP.ttf is actually in C:\Windows\Fonts.
Depending on how you installed the font, it could have been installed under your AppData folder (e.g. C:\Users\USERNAME\AppData\Local\Microsoft\Windows\Fonts).

Or it might be easier to test when you put the font in an ordinary folder (the one not for fonts) such as C:/Users/USERNAME/Downloads.

I hope either one works for you and your experience with Joplin gets more delightful.

Thanks.

1 Like

Holy cow - that worked! I didn’t restart Joplin hahaha.
I also tried it both ways - either system font or custom css will work once Joplin restarts.

Thank you Genneko!

1 Like

I’m very happy to hear that.
Enjoy Joplin!

Thanks again. Your help was tremendous!