Pre-release v2.9 is now available (Updated 15 November)

  • Improved: Allow electron flag to disable smooth scrolling (#6712 by @joserebelo)
  • Improved: New Embedded Pdf Viewer (#6681 by @asrient)
  • Fixed: Do not encrypt non-owned note if it was not shared encrypted (#6645)
  • Fixed: Fixed broken image links (#6590) (#6570 by @SFulpius)
  • Fixed: Play flac files (#6666) (#6434 by @SFulpius)

  • New: Plugins: Added joplin.versionInfo method (3b35ab6)
  • Improved: Add support for proxy (#6537) (#164 by Jason Williams)
  • Improved: Checkbox don't function while checkbox format button hidden from toolbar (#6567) (#6172 by @SFulpius)
  • Improved: Update to Electron 18 (#6496 by @alexmo1997)
  • Fixed: Allow styling note list items using custom CSS (#6542) (#5178 by Kenichi Kobayashi)
  • Fixed: App can crash with certain combinations of plugins (#6506)
  • Fixed: Search field focus is stolen on layout change (#6514)
  • Fixed: Search field would not clear as expected (#6557)
  • Security: Fixes XSS in GotoAnything dialog (e797ebb)

Tried to run appimage under Linux Mint 2.3 and the program does not run. System Monitor shows it's there, but no display.

Same here under Linux. Sometimes it gets as far as a window with initial menu, but doesn't progress beyond that.

Don't know if this is helpful, an attempt to run from the command line outputs the following:

~ $ ~/.joplin/Joplin.AppImage
xdg-settings: invalid application name
Try 'xdg-settings --help' for more information.
[54572:0812/] InitializeSandbox() called with multiple threads in process gpu-process.

Same for me.

Same for me.
Joplin 2.9.2, Ubuntu 22.10.

The console output is also the same.

@dayfuaim Try 2.9.3 available since 30 minutes.

1 Like

@bepolymathe Yes, I tried.
Thanks very much, everything works. :slight_smile:

Now it's the macOS app that's broken, I'm releasing another version

1 Like

The latest release hopefully should fix all apps: Releases · laurent22/joplin · GitHub


I confirm it’s ok on my side with version 2.9.4 (Fedora).

1 Like

Confirm that it works with Mint 20.3

1 Like

New release 2.9.11 now available:

If you try this release on Windows please could you let me know if you see a "SmartScreen" warning message like this?


The certificate has been updated and it seems Windows no longer recognises the app.

Yeah, I got this on the portable one:

Yes after the download a SmartScreen warning appears and you have to aprove the exe manually.

I did not get any message for the normal version...

Same for me, it’s ok without any message.

Ok so hopefully it was only a problem for the first few downloads and now SmartScreen has learnt it's not malware. I think it was the same the last time the certificate was updated.

'Smart Screen' warning this morning (1130 BST in UK), but ran OK on opening.
Many thanks for excellent product.

I also got the warning (24 Oct).

As well, after updating to 2.9.11, I'm only getting a white screen in the Joplin window. I've tried restarting the app several times. Beginning to worry.


So I tried restarting Joplin and restarting my machine. Same problem, just get a blank Joplin screen.
Tried uninstalling and re-installing 2.9.11. Same result.

I uninstalled and downloaded 2.8.8 (it just started downloading automatically from the "Download" google result. Not my favorite way of having things happen, but what to do.)
I installed that and everything is working again.

I'm happy to try and trouble shoot things. I'd rather be running a more recent version. Please let me know.

I'm running Windows 10.