Pasting from Joplin into Word/LibreOffice/OpenOffice

Operating system


Joplin version


What issue do you have?


I dont know how i got it working last time but i was able to preserve the beautiful markup text and code blocks when copy pasting from joplin into wor programs.

i am not able to get this working anymore i am not sure what happened

It was pasting beautifully before and i was able to change the text also from word

any idea? It is pasting now as plain text only and i tried paste as html using paste special but it doesnt work

thank you comunity

Other than the images, if I copy from the rendered window I get code blocks and tables and the rest just fine. Copy from the editor though and it is plain text as expected.

Weirdly enough it doesnt work for me anymore.

To reprodruce

in jolin editor markup write:


now if i try to copy this using the editor or the renderer i just get hello world and not the formatting with it

Copying from the PDF, it loses most all formatting.
Copying from the rendered view, I get an approximation, but that is it.
If I export to HTML and open that with LibreOffice, it does a slightly different, but better, approximation.

Working perfectly for me pasting into Libre Office. I'd include a screenshot but I can't attach images to posts.

I've tried and failed to reproduce the problem with LibreOffice on Windows. I did your simple hello world, but it copied properly. Then I did a fairly long file with a table of contents [toc] and lots of indented quotes, and lists. As long as I was in preview mode, not edit mode, it worked perfectly.

I suggest using only 1 writing program. Is it possible that the mac did an update and changed a default for editing style? You could try uninstalling libre office and then installing and leaving the defaults and see if you changed some variable that is doing this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.