Only one-way syncing between iPad and Mac

Allison joplin console log on sync 2021-09-17.txt (9.2 KB)
Allison log on sync 2021-09-17.txt (4.6 KB)

  • The version you are using. LATEST VERSION is not a version number!
    • Mac: 2.3.5, iPad mini: 12.3.1, (iPhone beta 15)
  • If it is a sync issue, please let us know what you are syncing with.
    • Mac to iPhone and iPad
  • The operating system you are using.
    • macOS Big Sur 11.6, iPad: 14.7.1

On my personal devices, using my personal Dropbox account, I set up Joplin to sync to Dropbox on my Mac, iPad and iPhone with no trouble. I’m now doing a video tutorial for ScreenCastsONLINE (an Apple-specific subscription training podcast) about Joplin, so I’m using a test Mac account, a test iPad (and a test iPhone). Everything was going swimmingly until I tried to sync to my test Dropbox account,

I set up sync on the Mac first, it gave every indication that it synced to Dropbox (and I can see files there). When I tell the iPad to sync to Dropbox and do the authorization, the iPad shows a lot of activity (111 things downloaded for example) but all I get on the iPad is the same Welcome (Mobile) notebook.

However, the Mac adds the Welcome (Mobile) notebook. I created a new notebook on iPad and it also synced to the Mac. So it appears that the iPad is doing a one way sync to the Mac, but nothing comes back to the iPad.

I tested this on an iPhone (but it’s running beta 15) and the same thing happens - I now have two Welcome (Mobile) notebooks on the Mac but nothing comes into the phone.

I deauthorized Joplin on, deleted Joplin from both iPad and iPhone, synced the Mac again, installed Joplin again on iPad and iPhone and set up syncing and got the same behavior.

I’m dead in the water on finishing my video for my due date on Monday. I can’t ship it without the syncing working.

The log on the iPad shows nothing at all when I switch to Errors only. Logs from Mac during sync are included but I don't see any errors.

What haven’t I tried?

What often happens is that the app downloads notes, resources, etc but not the notebooks. And because the notebooks aren't there, you're not seeing anything yet. This is a limitation that I'm hoping to fix in Joplin Cloud (and Server)

Are you sure that the sync was fully completed on the iPad? What does the sync status says in Config > Sync State. And any error or warning in the log? (Also in the Config screen)

I just let it sit for about an hour and nothing has come into the iPad yet. On the iPad I have a Syncronisation section in Configuration but I don't see sync state. At one point the iPad said:

• Created Local items: 76
• Created remote items: 9
• Fetched items: 111/111
• Completed: date/time

In my note I said that I looked at the log on the iPad and when I select Errors only, it's blank.

I'm wondering if I revoke access from DB yet again, and actively delete the data on DB, and only then request access again, it might kick things loose?

From the status, it looks like the iPad downloaded everything, which probably means that it's the Mac that didn't finish synchronising. Maybe try again to let sync run on Mac to see if it's uploading more data.

If it's still doesn't work you might want to check the error log on Mac - How to enable debugging | Joplin

I'm really confused, @laurent - I uploaded the log files according to the directions on my first post. Maybe I did it incorrectly?

I should also mention this is a VERY small demo library. Maybe a half dozen notes and to-dos, plus an imported notebook from Evernote with maybe a dozen notes with images embedded.

The notes I created have embedded images, one audio file, and a text file.

Right sorry I missed the log in the first post. Hmm, it seems to have worked fine so it's not clear why it's not getting the data on the iPad. What you could try is, on the desktop app, go to Configuration => Synchronisation, click on "Advanced options" and then "Re-upload local data to sync target". Then wait for it to fully sync on desktop, and then sync on the iPad.

Woohoo! That worked! This time it was 462 items syncing (before it said 111) and it took WAY longer to upload from my Mac.

Thank you SO much for communicating so quickly and being so helpful. I was really stuck on how I could finish my tutorial. Also, thank you for an amazing tool. In my initial blog post about it I said, “I had to double check that it is open source, because it’s pretty too!”


That's great, glad it's working now! And thank you for the kind words, we indeed try to keep things user friendly and nice looking, and thankfully there's lot of help on this forum to achieve that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.