Odd sync issue

Operating system


Joplin version


Sync target

Joplin Cloud

What issue do you have?

New iphone; installed Joplin, successfully connected to sync server (pressed 'Check Sync config' and got a 'Success'! message) but only a few notes have copied over. Now when I press sync it almost immediately tells me that it was completed but no further items are added. All of the files are present on Joplin on my Mac (version 2.12.19). I have 'fail-safe' ticked on the phone. Any suggestions please? Thanks!

As a follow-up, a message pops up at the top on the phone - 'Press to set the decription password'. I haven't done so. Could it be something to do with this?

That could be it!

If you enabled end-to-end encryption in the desktop app, notes are encrypted before being uploaded to Joplin Cloud. Entering the password originally used to enable end-to-end encryption should allow Joplin to decrypt the notes.

Read more about Joplin's end-to-end encryption here.

Here's a screenshot from the Mac - looks like encryption is disabled...

I deleted and re-installed Joplin on the iphone and successfully set up the sync again. When I clicked sync it synced the exact same items as before - 418 notes in two notebooks. Frustrating!

I've backed up my data on the Mac. Should I reinstall Joplin on the Mac as well? Any ideas gratefully received!

Ok, so I made a jex backup of the data, did a clean install of Joplin on Mac (deleted the folder in .config) and reloaded the jex backup, then synced everything to Joplin Cloud. All seemed to go well and over 2000 items were uploaded to the cloud. There is no encryption. So far so good.

I had deleted Joplin from the iPhone so I re-installed, set up and ran the sync, frustratingly with the same result - 561 local items created (as opposed to over 2000 on the Mac. Encryption is also turned off for the iPhone.

I'd really appreciate some help with this as I'm now out of ideas. Thanks

I'm not sure what could be causing this, but here are some things to check:

  1. Make sure that the date/time on the Mac and iPhone are both close to correct. An incorrect date/time has been known to cause sync issues in the past.
  2. Click on "All notes" on the iPhone. Are any of the otherwise missing notes visible?
  3. Go to Configuration > scroll down to Tools > Click on Sync status. How many notes/folders/resources are shown as being synced?

If the above doesn't help, you might also try the beta version of Joplin on iOS — it's possible that the sync issues are related to a bug that has been fixed in the beta version. (The beta version may have new bugs/regressions though).

The beta version also allows sharing logs, which might be helpful in debugging this issue.

Thanks for your help with this.

  1. Date and time on mac and phone are identical
  2. No missing notes in 'all notes'.
  3. Sync status shows Note: 455/455 Folder 5/5 Resource 25/25
    It's as if it can't see the other 1500 or so notes...
    I will try the beta version tomorrow.
1 Like

I haven't managed to reproduce this yet, but some users have reported problems with syncing notebooks that have certain Emojis in their titles (issue). Could this be related?

I deleted the emojis on the Mac and synced again. Progress! This time all the files synced to the phone but now all in one flat list (no sorting into notebooks). This is an improvement but obviously far from ideal. Thanks again.

I'm looking into the issue now.

From the testing I've done so far, it seems related to initial sync — notebooks with emojis that existed before doing an the first sync don't sync at all. Notebooks imported after an initial sync seem to sync as expected (even if I export a notebook that wasn't syncing correctly, then re-import it).

This is just based on a few minutes of testing, though! (I only had one notebook with emojis before the initial sync).

Hopefully this will be fixed soon!

I've downloaded TestFlight. Can I get an invitation to Beta test Joplin so I can install the latest? Thanks

Here's the invitation: forum post

I'm able to reproduce this with the latest Android build though, so I don't think the TestFlight release will help. (At least not until the issue is fixed, which will hopefully be soon!)

This might help:

  • Do an initial sync on iOS (get it to a state where things aren't working correctly, but it says everything is synced)
  • On the Mac, export one of the notebooks that isn't syncing as JEX
  • Re-import the notebook on the Mac (so there's two copies).
  • Sync again

The imported copy of the notebook might sync (see issue comment).

Edit: From the Mac, the following may help:

  1. disabling note history (settings > note history), then
  2. going to "Syncrhonization" > "Advanced" > clicking "Re-upload local data", and finally
  3. reinstalling the iOS app

This will take a long time, so I don't currently recommend it.

Exported a notebook as JEX and re-imported. Synced again, no change.

Disabled note history, clicked "Re-upload local data" and re-synced, reinstalled iOS app. Back to syncing about 500 again! Should I try disabling Note History in iOS as well? (EDIT - tried that - didn't work, although it did download about 900 notes???)

Sorry to be a pain - this is driving me crazy!

A post was split to a new topic: Sync issue

I don't know if this is related but there was an issue in Joplin Cloud which means it wouldn't sync all notes right away, and you'd have to click Synchronise again to get all the changes. This is now fixed so it might be worth giving it another try

Hi Laurent - I have synchronised several/many times with no change in the result. Something I just discovered that may be relevant. Although I have deleted and reinstalled Joplin on my phone, when I go to Settings/Encryption Config I see that encryption is: disabled and master password: loaded (as it is on the Mac) there are 3 encryption 'Master keys' saved which I seem unable to delete. Could these be the cause of the problem and if so how can I get rid of them? Thanks for your patience!

It shouldn't be related to the master keys (though enabling encryption could be another thing to try!).

Master keys are used for end-to-end encryption. If they're disabled, they shouldn't be used to encrypt notes.

If you're using the TestFlight version of Joplin, you have the option to share a log. To do this, go to Configuration > Tools > Logs > three dots at the upper right corner > share.

Alternatively, you could try a different sync target (e.g. Dropbox or OneDrive). If sync works with a different sync target, this tells us that this is likely a bug in Joplin Cloud. If not, it's likely a bug in Joplin Desktop or Joplin Mobile. (Dropbox and OneDrive sync will be much slower than sync with Joplin Cloud).

Thank you for helping us fix this!