No confirmation email

I am running version 2.7.4 through Docker on my Synology NAS.

When I try to register my email and change password, I get the following message:

"A confirmation email has been sent to your new address. Please follow the link in that email to confirm. Your email will only be updated after that."

I have never received the confirmation email. I used the same email that I used to register for this forum. I tried doing this a few times. I even tried another email address. I also check my SPAM and nothing is there. Am I crazy? Thanks.

Did you configure the mailer? Also you can check in /admin/emails the email queue and statuses

This post might help if it is the same issue

I didn't know that I needed to do that. Where do I go to do that?

You need to edit your .env file, then rebuild the app container.

I am an amateur when it comes to these things. I used a guide on Marius hosting to set up my docker container. Where is the .env file located?

I wouldn't know how Synology handles Docker, I only use 'bare metal'. I would presume, though, at the same place where it was initially downloded as it's needed to set up the containers in the first place.

The text in Step 12 of this guide (I think you meant that one?) is the docker-compose.yml file. Here you can edit the environment variables under services - app - environment. As of the thread @Daeraxa mentioned, the final file could look like this with you personal information added:

docker-compose.yml
version: '3'

services:
    db:
        image: postgres
        volumes:
            - /volume1/docker/joplin:/var/lib/postgresql/data
        ports:
            - "5435:5432"
        restart: always
        environment:
            - POSTGRES_PASSWORD=joplin
            - POSTGRES_USER=joplin
            - POSTGRES_DB=joplin
    app:
        image: joplin/server:latest
        depends_on:
            - db
        ports:
            - "22300:22300"
        restart: always
        environment:
            - APP_PORT=22300
            - APP_BASE_URL=https://joplin.server.com
            - DB_CLIENT=pg
            - POSTGRES_PASSWORD=joplin
            - POSTGRES_DATABASE=joplin
            - POSTGRES_USER=joplin
            - POSTGRES_PORT=5432
            - POSTGRES_HOST=db
            - MAILER_ENABLED=1
            - MAILER_HOST=smtp.gmail.com
            - MAILER_PORT=587
            - MAILER_SECURITY=starttls
            - MAILER_AUTH_USER=my_email_address
            - MAILER_AUTH_PASSWORD=my_password
            - MAILER_NOREPLY_NAME=JoplinServer
            - MAILER_NOREPLY_EMAIL=my_email_address

Best regards

Now we are getting somewhere. I appreciate the tip. I will try it out. Thanks.

1 Like

This worked. Had to update something on gmail's end that it didn't like, but everything worked. Thanks.

1 Like