Server doesn't sent mail

hi, i'd like to introduce Joplin to my wife, so i created a new account for her on my self hosted Joplin server (on a synology, docker instance).
But she has to confirm a mail, which is never send to her, although the server says so.
Could it be that the mail function in the docker server has been stripped for perhaps efficiency reasons for instance?
Is there a way to overcome this problem? So that my wife can connect to my server?
Joplin Server 2.7.4 on a docker container on my synology DS216+ll
postgres container version: 14.2-1
thanks a lot,

Check the log when the server starts - it should tell you if the mailer is enabled or not. Also check the emails under /admin/emails for any error.

Have you set up your SMTP server settings in the Joplin server environment variables?

If so, did your SMTP settings work before v2.7.4? There was a recent post for v2.7.4 where one of the environment variables for setting up SMTP changed to MAILER_SECURITY=.

However when testing Joplin Server I rarely configure SMTP and just leave it switched off (the default). When I create user accounts (and set their password at the same time) the user account can log in and sync without needing to click anything in a confirmation email.

If you still want to confirm the account but without email, the admin can login and go to the email tab and select the message.

It will display the link, which can be copied and used manually.

hi, thankxx very much for your answer.
I made a mistake in the smtp settings (MAILER_SECURITY).
Now it is working like a charm and i can mail my wife.
Besides that i learned how i can copy this link from my admin account.
Again, thank you all very much an Sorry for bothering you.

Nothing to be sorry about. This is what the forum is for! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.