Lost notebooks

I have been testing Joplin as a tool for doing web research. Initially I was collecting random pages and confirming the results. Later, I created new notebooks and started collecting data relevant to work. All went well - I will suggest some features in a “Feature request” post.
Last Saturday, I opened Joplin to review some notes and had only what appears to be a default notebook. I had around eight separate notebooks - all no longer visible. After a good round of cursing, I looked at the folder…
Tangent: I was using Joplin portable, residing on a secondary drive, Win10, current update. Further, I have my system set to hibernate - it is an older system and takes a long time to boot. I would add that I have been successfully operating this way for months. The only significant change recently is I started using a VPN and have had some small ripples with that.
…To continue, I did some reading and some poking around. I found an sql database that, on examination, seemed to contain my data. I can [probably] pull out that data with another tool…I would just prefer not to.

To my question: How can I get Joplin to open the relevant database?


Not sure what your problem is, but this is what I would try first. My guess is that for some reason the path to your joplin data directory has changed, and when you started joplin it couldn’t find your data, and so it created a new data folder.

First, make a backup copies of all the joplin data folders you have found. For example, on my computer it is c:/Users/mic704b/.config/joplin-desktop, which is the default location.

Then start Joplin using the --profile option, pointing to the folder that contains your database. For example

Joplin.exe --profile c:\Path\To\Joplin\Data\.config\joplin-desktop

In Joplin Options, General, the Notes and Setting are stored in: C:\Users\admin\Downloads\JoplinProfile
The database I want is in D:\JoplinProfile

Is there a way to change that setting in Joplin?

As stated before, I am using the Portable version.


Yes, that is what the --profile option is for.

You need to modify the command you use to start Joplin, and add the following to the end of it --profile D:\JoplinProfile.

I don’t know any way you can edit that setting in Joplin while it is running.

That is precisely the command line I entered before my last reply. Still loads with a configuration from when I first started testing Joplin.
I thought that perhaps an earlier version of Joplin would go to the right database. In fact, it did not, and curiously, it went to the OPTIONS page that I was on when I closed the current version. This suggests that there is a configuration file that Joplin reads in on execution. That file is what I need to change…just can’t seem to find it.

Oh, OK. That is strange, I’ve not seen it start on the options page.

If it says C:\Users\admin\Downloads\JoplinProfile in the options page, then it is as if it didn’t take notice of the --profile option or it can’t find the path.

My only other suggestion is you could try copying your D:\JoplinProfile to C:\Users\admin\Downloads\JoplinProfile, and then see if your notes appear. You could then use Joplin to export your notes, in case you need to reinstall or something.

That was the next step - will give it a go this evening. I still have to believe there is a config file that is read in, somewhere.

Resolution - although not final.
At last account, I was using the portable version of Joplin, located on a secondary hard drive, and was in the process of re-pointing Joplin to the right database file.
Steps taken since that point:
The Plan - rename (to preserve) the support folders on both at D:\JoplinProfile drive and C:[Path from root]\downloads\JoplinProfile. Next, from the D: drive, run a newly downloaded version of Joplin portable.

  1. Rename the support folders from JoplinProfile to xJoplinProfile. Although there were no running instances of Joplin running (had TaskManager running and checked). This process failed - error was some file was open in the folders.
    1.1. Entered the folders, created a new folder inside and moved all the files and folders into that new folder - effectively emptying the location that Joplin writes to.
    That worked on theDC:\JoplinProfile folder but not on the C:…\JoplinProfile folder - a folder named .sync insisted that a file was in use.

Started down the “Why is it doing that?” rabbithole, but caught myself in time.
Plan B emerged.
Copy my intact database to the C:…location, export the notebooks to JEX, move everything over to D: and import.
Net result was that I was able see my notebooks in Joplin, export them, import them in a new instance of Joplin and so, my data is intact.
I have a few “Howevers…” though.

  1. Even though the C:|…\JoplinProfile on the C: drive was cleared, when I ran the new version of Joplin on D: (showed just the default notebook) and then, imported my JEX backup, a copy of my restored data appeared in the C:…JoplinProfile folder. The new version of Joplin should not have even known about that folder.

Since I was not able to find any configuration files that loaded path data when an instance of Joplin started, I (finally) thought that perhaps Joplin Portable made registry changes. Will look into that as time permits.

If that is so, then that version is not truly ‘portable’ - it is leaving a footprint on the system it runs in.

Why I care…Joplin has a lot of potential as an investigator’s tool, in the role of recording internet browsing. However, if the portable version writes to the target system’s registry then any information is tainted.

I didn’t understand everything but for the profile it’s simple. There are three different way the app can access it:

  • For the portable app: it looks in the adjacent folder “JoplinProfile”
  • For the regular app: it looks for it in ~/.config/joplin-desktop
  • Finally you can override this by using the --profile flag

There’s no other way, no magic config hidden somewhere and no registry key.

**D:\JoplinPortable.exe --profile D:\JoplinProfile** was the first suggestion provided by mic704b - and did not work.