Joplin removed data on upgrade?

Operating system


Joplin version


Desktop version info

Joplin 2.13.13 (prod, win32)

Client ID: 80055633ada244cc90e433473cfd310d
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: c3cdeeb

What issue do you have?

Joplin sent me a nag screen to upgrade, installed upgrade, all notes appear to be gone.

Log file

log.txt (9.54 KB)

After clicking "About" and copying the output as requested, Joplin crashed.


It's not that the data was removed, it's just using a completely different and new profile. Whatever profile you had before is not being used now.

Did you previously use the portable applications by any chance?

Or was the app previously installed for a different user or for all users?

In any case your profile is still there in one of the user folders. One of them under C:\Users\SOME_USERNAME\.config should have a joplin-desktop folder and that will be your profile. You can copy this folder and paste it in C:/Users/user/.config and it should work again

The username is "user"


There are no other users.

I don't think there's any other .config folder on the computer.
and there's only one "joplin-desktop"

I've been migrating from Evernote, I used .enex files which I still have, so it's only the work I've done in Joplin since September that won't be recoverable.
So what does the installer do?
Does it detect and then wipe previous Joplin installs?

If you can please tell me what files I need to get I can try and restore them from backup.
I can overwrite the .config folder with the restored one maybe?

Thanks for taking the time to help me out :slight_smile:


Mick Winnett

1 Like

Yes the file you'd need to restore are .config/joplin-desktop and no the installer doesn't delete the profile, so I'm not sure what happened. It simply reinstall the executable and doesn't even have a reference to the profile path, so even if there was a bug it wouldn't delete the profile.

1 Like

thanks Laurent,
I probably did something stupid,
I'll check and see if my backups are working :wink:

kind regards, et merci

mick winnett


@archwaygunner - I have had this happen during an upgrade. A quick reboot of the computer has almost always fixed it. Dunno if you tried that.

One time I had to down-grade my Joplin back to what it was, that got my profile back. I ran a quick JEX backup. Upgraded, and restored, off I went. That was the worst I've had happen. It turned out there was a captured "clipped" HTML web page file, in a note that had brought the new Joplin to a standstill. I deleted the note and re clipped using "simplified page" That fixed that.

Let us know what you find out, I'm curious.

thanks Laurent, Macrium Reflect to the rescue!
have copied over from 1 Jan backup so happy with that!
I think i'll set up some dropbox file syncing now!


It's been rebooted, there's just been a windows update on my box.
(I didn't notice it'd happened immediately.)
Anyhow, I should have setup syncing! :wink:


Feel for you buddy. It's happened to me. My solution was to grab the plugin "Simple Backup" I downloaded and configured it to save JEX file every few days. It's saved me a few times, mostly from my own folly.

Thanks for the tip!
I have a weekly macrium backup as well as the dropbox sync set up now,
I'll check that app out, two backups are better than one! :smirk:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.