Home / GitHub Page

Lost notebook...no syncing involved

Joplin 1.0.201 (prod, win32)
Client ID: 35119e4651ac4baabcd82c13c9d404b2
Sync Version: 1
Profile Version: 28
Revision: e65af8c1 (master)
Problem:
Last used Joplin about 2 days ago. It’s a portable verion, on 2 year old win 10 PC. Didn’t bother with syncing.
Opened J again today (using listary - double click CTRL and choose program to run).
May or may not have selected the portable J I was using (could have also been the file I originally downloaded then copied )
Long story short…when it ran, new notebook. All previous files gone, except for image files used in some of the notes.
FWIW, the sqlite database file is 7,188,480 b, modified 2 days ago. The log has no entries for past 2 days either
Am I out of luck getting back the notes I’d created?
Thanks

Then try opening Joplin you have been using for 2 years.
It seems you have opened a different version of Joplin (not the one you intended to)

Btw, syncing doesn’t backup files. You have to archive them elsewhere by exporting as JEX

Thanks for reply. yes, seems so, but in process it may have overwritten the database.
Using the program “everything” to search for all locations joplin appears on my HDs, I’m unable to locate any .md files.
…a bit later …I had already tried using “normal” version of Joplin, to no avail.
Just now, tried AGAIN. All files back. So weird. And to emphasize, I did try opening the usual version yesterday. So all is good, apart from wondering “what just happened?”
And thanks for drawing my attention to exporting as JEX. Done immediately, to 2 separate locations.

That’s because joplin does not store your notes as md files locally. Search for database.sqlite