Linux issues

hii,
as i am transit from samsung note and evernote…etc to joplin (i dislike other notes app because lack of feature to allow user to back their own data without relying on their system, joplin promised a independency, won’t be controlled by any company thru any platform sync),

**don’t think that i am not appreciative when such lovely group of ppl who develop joplin open source and free… i appreciate them very much. if i have sounded like showing no appreciation, pls forgive me. **

1.joplin android
i realized joplin android saves data that i write every few “changes” when i type a few words, it saved the data already (can see the save button toggling). i think this is not that good, it is good if user can choose auto save or manual depress the save button.
the reason being, in touch screen of smartphone, there is always tendency to accidentally select a whole chunk of data and delete before realizing it. When the auto save feature kicks in at that moment, it would be the end of everything… because usually user won’t even know what has being deleted accidentally.

  1. joplin linux (manjaro xfce)
    since i want my data to be sync on desktop and android all the time, so that i can have my data on laptop when i need it and can enter data when i am on the move with android…
    but when i started to key in data on joplin linux, i realized many funny little bugs… appears like the software is in totally development… else how can it be there when after years of usage ?
    for example,https://imgur.com/jEiR3UK.png
    why my last 2 lines of notes… the resultant display is different from the rest ?
    and there is no where for me to know what when wrong, can’t correct it… no nothing to change setting or anything…

  2. joplin linux
    where is the “save” button on joplin linux ?

  3. joplin linux
    https://imgur.com/8FLMnrO.png
    this is what happened when i try to delete a note in joplin… boxes upon boxes.

  4. joplin linux
    there is no find next feature in joplin linux
    when i entered a lot of notes in it, i need to search for it… even though there is “ctrl+F” to find the word in the current note, but i have to scroll thru so many “highlighted” word for the one that i need. it will takes a lot of time… and might missed it when scroll too fast.

  5. there is not search thru all notes for a keyword function.
    i have many many different notes in it, when i don’t remember which note has got the thing i need, how do i search to the file and to the data ?

if i missed out some thing, pls correct me, i am always ready to learn.

tq ppl.
thanks Joplin developers… your effort is great.

Joplin Linux is the same as the other builds, it has the same exact same features, expect keychain support is currently missing.

A. All software has bugs. Even decades into development. So … there’s that.

B. I haven’t investigated all your issues, but the screenshot you provided in #2 isn’t a bug. Remember, the text you enter in Joplin can be rendered to something pretty, but only if that text is in markdown format. You have some commands line saved examples as your note. Change the layout so you don’t see the rendering (or ignore it) because … your command line snippet isn’t a text file of markdown. It’s random text essentially.

@andrew_ysk :point_down:

where is the “save” button on joplin linux ?

Ctrl + S ?? or the synchronisation button in the side bar, bottom left corner.

this is what happened when i try to delete a note in joplin… boxes upon boxes.

Unable to reproduce on Manjaro XFCE my friend. Need more details please.

there is no find next feature in joplin linux

You mean this?
image

there is not search thru all notes for a keyword function.

Ctrl + G

I have a feeling this has more to do with your system installation image and not necessarily Joplin. I could be wrong though.

  1. Mobile definitely needs undo/redo at some point, but this is indeed missing.

  2. Your issue here is that $ is reserved for math expressions. You can check the markdown guide for more information. If you won’t ever use math in your markdown you can disable the math plugin under Tools -> Options -> Plugins.

  3. No save button, it will autosave

  4. This looks like a font issue? I don’t think I’ve ever seen this reported before but I suspect you are missing a required font, but I don’t know why the font wouldn’t be bundled.

  5. If you hit enter with the search box open it will find and scroll to the next match. Is that what you’re missing? I don’t really understand the problem. Also there are 2 arrows in the search box for find next and find previous
    image

  6. I’m sorry I don’t understand this. Joplin has a search bar at the top for searching through notes.
    image
    And there is an ongoing project for improving the search.

For Undo on mobile it’s already available on the APK version and should be on Play Store soon. Also keep in mind that there’s a history feature on Joplin so, even if you accidentally delete some text, it’s not the end of everything. You can open the note history on the desktop app and find what you’ve deleted (unless you’ve added it very recently and deleted it soon after).

2 Likes

i don't get you.
even on linux joplin there is no undo.. :slight_smile:

@t0dd
i also solve the issue… by remove the plugin of math… as suggested by CalebJohn.
good enough for me.

You can try Ctrl-z and Ctrl-Shift-Z. These are the standard undo/redo keys.
You can also check the note history by press on this key.
image
And then click on the blue text here.
image

1 Like

Math plugin: has no bearing on what you were referring to. I’m not following.

Undo on Linux: works like any other application’s undo: CTRL-Z and CTRL-SHIFT-Z. It’s the same as any application on any OS for that matter, I think.

Mobile generally doesn’t do undo well, or at all. Hence, mobile is not really the ideal writing environment.

hii,

thank you. you gave me many good tools for joplin.

CTRL+G is a global search, just the one i was looking for, although the search result is in weird format.. (and it does not do highlight when i clicked the search, but at least better than nothing.
for example, see in photo, i did a global search of "flower".


the result comes : 4 result in 2 different files.
when i click "flower from wikipedia":
it brings me to the document, but where is the "flower" that i was searching for ? i have to scroll thru the whole document "to look for the word that i was searching for ". this is not possible. :fearful:

ctrl+f (current file search), this search also does not highlight the search result. (i have to read line per line to "search" the word among so many words. )

F6 (search , unknown what for , no function) this search do nothing. i tried to search for word document.. but it blink and do nothing.

The search features in Joplin are weird. Laurent (and others, I believe) has been investigating how to improve that for the more general “search in editor” case. That’s my understanding anyway.

F6 will generate a list of notes that contain your search string. It’s not a bug. It’s just how it works.

CTRL-f highlights the search string throughout the document. Rendered document only. Which is not overly helpful if you are looking for it in the source text. But that’s what it does. It’s not a bug. It’s just how it works.

1 Like

Even F6 does not work. pls refer the the above post of mine with 4 photos attached as proof that none of the search works well… especially F6…

F6 worked. You searched for the word document. It listed all notes with the word document.

the problem is the auto save does not save in time.
i tried at one event, i wrote something in the note, and immediately i went to search for it, it does not appear in the search.
only after i pressed “ctrl +s” then the result appears in search.

also, for ppl like me, it makes me “paranoid” not to save my note MANUALLY… because i have experienced a lot of lost in my note… in many software or os… , eg: system freezed, software crashed… all those note were gone… so pissed off… if you write a page of document, and it just gone without saving… how scary is that ?
no body will rely on a software to auto save… . sometime i will write something “temporary” on a note, but it is not meant to be save into the file… that autosave is good , but if user can’t manually set to autosave or disable autosave , it is not good. if there is no “save button” for us to manually make sure note are save (to give peace in mind), it causes paranoid in my mind. lol

So. Use CTRL-S then (the “save button” which is the same in every single other application).

I export to a .jex file periodically as well since I have hundreds and hundreds of notes, to include the novel I’m writing (about 90,000 words long at this point).

i just did a search on playstore, there is only 1 joplin apk. there is not another joplin that has "undo" on it.
and my android joplin was just installed 2 days ago..

wow! you are a writer ? :smiley:

ctrl +s does not save file.
it syncs file.
which i have not able to setup yet..
because i don't trust my data to be on "cloud" since cyber security is getting worst by the day.
hence i try to learn to setup "syncthing" .. but no time yet, because a lot of issue pop up here and there. for every problem i tackle, there pop up more problems.. such as these issue with joplin.. lol faint

What issues? What problems? You mean learning the interface? It’s not overly complicated, but for many things, as we pointed out, it just works like anything else. Thus far you just pointed out learning curve items. Laurent is well aware that there are Joplinisms that need to improve over time.

Yeah, the CTRL-S is a sync. But it saves locally first. Plus it simply autosaves quite often (every few seconds? I’m not sure.) I sync to Dropbox, fully encrypted. So if Dropbox is sharing every piece of data to the Guvment I’m not overly worried.

Mine has it

But that’s because I’ve built it from sources.
The version in Play store will have it in the next update.

Btw, Lauren thanks for adding this. I was about to start looking into implementing this myself and then noticed those buttons…

4 Likes