Linux issues

hii t0dd,

it does not work here…
i saw the word “Reader” in the note somewhere before… i am sure of it.
then i used “CTRL+G” to do a global search and confirmed it is in this note.
i clicked the result to go to the note. and then i do a “local note search” (CTRL+F), but i can’t find where on earth is the word “Reader” …
it doesn’t work for me. no highlight. i browsed thru the note, but ican’t find the word “Reader”, even after Ctrl+F.

There’s an ongoing project to rebuild Joplin’s search. It will get much better.

3 Likes

ok. i c.

you build it yourself for android platform ? or for linux platform ?

Android, I do not use Linux.

To be fair I do not use Joplin on Android much these days either -- I'm at home most of the time anyway.

Andrew.

CTRL-F will highlight the word in the rendered document. Not in the editor. You are looking at the editor. Is this ideal? No. Are folks working on a means to add search to the editor as well? Yes. But right now … that’s how it works. If you click the layout button and unhide the rendered document, the word you are searching for will be highlighted … assuming it is there.

I think what we need here is a bit of a summary.
Ctrl-G is not a search, it’s the goto-file command, this is why you’re not seeing word highlights.

F6 and Ctrl-F. The current Joplin editor component does not easily support highlighting of words Luckily a new editor is being worked on that will replace it and highlight words in the editor and the rendered view see this pull request. For now you need to have patience.

Mobile Undo/redo. This is currently only available in the development version of Joplin. You must either build the app yourself or again please have some patience and wait for the next android release.

In regards to auto-save, I don’t think the behaviour will change, Joplin is note taking and management tool not a text editor.

@andrew_ysk please understand that Joplin is an in development open source application, this means that it will always be changing and improving. But it won’t be as stable as a commercial tool and the updates won’t happen as quickly either. Pointing out bugs is always appreciated (because it helps the devs locate common issues), but unfortunately some issues can’t or won’t be fixed right away and it is up to you to accept that or not.

1 Like

Hii CalebJohn,

i was locked out by this forum because i posted too many msg … because i am a new comer to the forum… i guess that is spam protection mechanism of the forum

i understood Joplin is under development, i accepted it, because i have not use any other note taking app that sync cross platform and device. so, i am willing to try to adapt to it.
the whole joplin interface is to me a stranger… because i just have not being using app such this… with markdown mode and demo wysiwyg and sync… these are relatively new to me. and the function of each feature is not that clear to me too… (although with the help of the friendly community here, i get to know abit more, still i have some feature that is not so sure).

anyway, i have started to use feature to sync with dropbox just now.
it was fine. then i used encryption mode, something messed up. or i messed up the process.
now, i have all the notes on linux laptop, but android notes got conflict. hence i removed all android notes (because i have got it on laptop).
i encrypted laptop note and also encrypted android note , each with same password… i think this is where i screwed it up.

i should have sync both devices to dropbox,
than only encrypt at laptop side and re sync .
then i should have just remove the android notes…
and then resync to get the dropbox encrypted notes sync to android device.
now i am stuck… don’t know how to get the notes back onto android device.
still reading how to get it solve.

my android device shows:
PRESS TO SET THE DECRYPTION PASSWORD.

When i tried to sync my android devices, i saw it sync status:
deleted remote notes 1…2… 3. .4 …10

i was scared that it will delete my notes on dropbox… hence i interrupted android device.
but upon inspection on dropbox, the files are still there… although i have no idea which is the file, (there are so many files on dropbox, while i have only 3 notes…, i guess the remaining files are history staggered)

now after resync my android again, there is only 1 note appeared…
it names is

Encrypted

and
there is a yellow highlighted line on android phone:
Press to set the decryption password.

if i get the encryption solve.. 
i would like to try local ethernet sync or bluetooth sync or mtp sync (syncthing).. if those are available. 
i don't like the idea of using mobile data to sync. because my mobile data is limited. 
when i am outside on the move with android device, i wouldn't want the joplin note to keep save and sync to dropbox.. i would like to do manual sync when i reach home (preferred non cloud related sync, i mean why should i sync to cloud and back to my laptop, since my laptop is just beside me and android device ? )

[quote=“CalebJohn, post:27, topic:9535”]
understand that Joplin is an in developm
[/quote]Preformatted text

Quibble: There is no reason an open source project can't be as stable as anything else. And when you say "commercial" I assume you really mean proprietary. Anyway ... Linux itself has for almost it's entire history been far more stable and bug free (and certainly more secure) than Windows, just as a for example. There are a great many open source projects that are extremely stable, and to be frank, if they have a robust community, they tend to have fewer security issues and bugs than comparable proprietary products.

Desktop applications tend to be a bit more cutting edge and bugs are more tolerated because desktop applications are generally not mission critical. Joplin has a young, but growing community. In the few years I have been mucking with it, it has been extremely stable and relatively bug free. It has quirks, just like any project/product but those quirks are slowly being addressed. We have had one major issue in all this time (that I can recall), and that was ironically linked to a Linux kernel, of all things. It was more of a conflict than a bug I think.

Just a quibble. As this community grows, and it depends on how Laurent wants to run it, I can see Joplin really getting a lot of traction and with that, striving for a more and more disciplined approach to release and testing, etc. But even if nothing changes, he's doing a tremendous job and the stability of Joplin is testament to that.

...

That was supposed to be a short blurb. I let it get out of hand. Apologies. :wink:

1 Like

Are you using the snap by any chance? Try the AUR package or the official AppImage.

it's good, no problem, i sometime like to listen a bit of such linux and idea and stuff.. i personally like open source thing. i hate proprietary thing.. but at the unstable state of growth is really... a pain in the ass. lol. if only i can program, i will even fix it myself .. lol
i also hope joplin will be good, if i am a programmer i will join in to help also to create a software such this to cater for everybody uses.. i would want a software such this, surely other ppl would want it too.. but sadly i only learn c++ in school, and never really make any real program.. hence i regretted.

i was using snap.. later i did change build it from aur. hence the font issue solved. but sync got a lot of issue.. especially automated sync.. i just tried 2 days... and i gave up. that's why i think the most stable sync is sync with manual control, can tell it which data is priority . and can change to manual sync (instead of auto sync all the time).. so, sometime i just temporary type something in note; and needed to delete later,. those kind of content in the note need not to be auto sync.. ..

i wish joplin community all the best..
right now , i will opt for vim on android and just syncthing it to vim linux..