Homepage    |    GitHub    |    API    |    FAQ

Large notebook not synching via Joplin CLoud

Hi. My collaborator and I just subscribed to Joplin Cloud and cannot sync a large notebook from my notes to theirs.

I imported all my Evernote notebooks, including one for a project we're working on. It's got 258 notes in it and a lot of attachments.

When I tried to share the notebook, the request showed up on their Joplin, but all that happened when they accepted was the creation of an empty notebook. They created a new note that synced to my copy, and my edits to that synced back to their note, but nothing else showed up on their end.

I unshared the notebook with them and shared it again; now the "hey you have a new shared notebook" banner is at the top of their screen, and nothing happens when they accept it.

Here is a screengrab of the errors they get when doing that after turning on logging:

If I try to share a smaller notebook it syncs just fine.

I am on Joplin 2.4.9, on OSX 10.14.6. They are on Joplin 2.4.9 on Windows 10 Home, version 20H2, OS build 19042.1237, Windows Feature Experience Pack 120.2212.3530.0. Dang Windows versions are long-winded.


Also we just tried to delete the offending notebook on my end and re-import it from the .ENEX file it started life as and now Joplin is giving me a "cannot create a string longer than 0x1fffffe8 characters" error and I think maybe it's time to have another look at the other options for replacing Evernote, what with collaborating on this specific notebook being a hard requirement for us.
![Screen Shot 2021-10-12 at 5.03.36 PM|437x153]

Sharing happens via sync, so you need to wait for all the notes to be synced after sharing, then your collaborator will also have to wait for everything to sync.

It might take a bit of time if your notebook is particularly large.

All notes were synced before sharing.

We've waited a while after accepting the share but absolutely nothing shows up beyond the notebook name; the sync status above the synchronize button says it's done, and pushing the synchonize button again does nothing. This is in sharp contrast to seeing the sixteen notes in a notebook that shared cleanly start popping up in the "all notes" view immediately after accepting the notebook.

I'm noticing that it seems to want to update a bunch of stuff on the server after I attempt to share the notebook - is it going through saying "share this" on all 258 notes in this notebook?


And all that said, it seems to have now finally shown up on their machine.

Yes that's pretty much what it does, so when it's a large notebook it can take a bit of time when it's first shared. That might be optimised in a future version.

As for the enex bug, I'm aware of it and it should be fixed soon.

A "hey this may take a little while to show up on your friend's notes" alert when sharing something large might be nice, for one of those "I want to work on Joplin but don't want to tackle serious issues" days.

And hooray for already having the enex import bug in the pipeline! Thanks.

(Sorry if I sounded grumpy earlier, basically any contact with Evernote in its current state makes me super cranky.)

No problem, the sharing system is an important feature, yet it's also one of the most complex part of Joplin, so I'm always keen to hear how it's used and what problems may be found.

Initially the idea was to make sharing fast enough that additional messages are not needed, but for large notebooks an alert or something would indeed make sense.

Regarding the ENEX import issue, it's now fixed in v2.4.12 (will soon be in v2.5 pre-release too) so you might want to check with this one: Release v2.4.12 · laurent22/joplin · GitHub