Joplin-vscode-plugin roadmap

I'm really sorry, I wasn't able to test it successfully, I don't know what went wrong.
My procedure is as follows.

  1. Upgrade joplin to 2.88, upgrade vscode to 1.67.1
  2. Install the joplin-vscode-plugin0.7.9 you gave in vscode
  3. Use the excalidraw in vscode to draw a diagram and save it as SVG on the desktop
  4. Drag this SVG diagram into joplin's test notes
  5. open this test note in vscode, ctrl+mouse click on the attachment
    But there is no response. There is no prompt.
    I think it should be a wrong operation, but I don't know where the problem is, I hope to be corrected. Or you can write a simple tutorial if it is convenient, thanks.
    VeryCapture_20220611230815

Try the shortcut keys ctrl+j, ctrl+l to list the resource list of the current note, and then select one to edit it, this error that occurs from time to time is the main reason why I released 0.7.8

can also be triggered by entering the command joplin show resources in vscode

Also, it looks like your markdown preview is not showing the image correctly, refer to the faq: FAQ | Joplin Utils

Yes, it's great, the preview problem is solved, the solution is to un-disable the upper right corner in the previous illustration.
But the problem with opening with excalidraw I still can't figure out.
Clicking still doesn't jump to the interface of excalidraw.
Rest early, I will test again tomorrow if I have time.

VeryCapture_20220611235311

I added some logs and rebuild, can you reinstall this version and try again?

  1. Open note
  2. Use ctrl+j,ctrl+l to display the resource list
  3. Select Open Resource
  4. Enter the command joplinNote.showLogFileDir to open the log resource directory
  5. Send me the two log files as a zip

joplin-vscode-plugin-0.7.9.vsix (761.1 KB)

Looks really cool! Could work well until proper drawing support is added to Joplin itself. Thanks!

1 Like

0.7.9 has been synced to the vscode extension store

1 Like

Release 0.7.10, mainly to fix the inconsistency with the behavior of joplin in external editors when there is a first-level title in the note content, related issues: [Bug]: Note name breaking · Issue #47 · rxliuli/joplin-utils · GitHub

Released 0.7.11, glad someone is using it and asking questions

2 Likes