Joplin Server sync issue — "No such master key"

Operating system


Joplin version


Sync target

Joplin Server

What issue do you have?

I just transferred data from an old iPhone (on which Joplin sync worked and continues to work fine), and while the target configuration works, attempting to sync gives the error "No such master key." E2EE is not enabled. I'm not sure why there would be a master key set, or where to find it so I can delete it.

Still haven’t been able to find a solution to this, and it’s making Joplin unusable for me. Here is the error log that is generated every time I try to sync from this new phone:

Again, E2Ee is not enabled. Here’s the encryption config screen

Please confirm ...

  • same versions of Joplin on both devices ?
  • old iPhone uses (or doesn't use) encryption ?
  • if yes, you know the master key ?
  • you have tried to remove and reinstall Joplin from the new system ?

Yes, both devices are running Joplin 12.12.3.
The old iPhone does not use encryption. No client for this account has E2EE activated.
I have tried removing and reinstalling Joplin from the new phone, more than once and with a delay of several days + power cycling to clear any spurious cached data. The problem persists.

It seems like the same thing that happened to this person may have happened to me. But they were using Dropbox for sync, and were able to edit a json file to remove the spurious master key. I have no idea where this file would be found when syncing through a Joplin Sync server.

I am not saying "do the following" but here is what I would do if I had the same problem.Please understand, I cannot say there is no risk.

  • backup all data
  • uninstall Joplin from all devices
  • run a "cleaner" on old iPhone (found in appstore etc.)
  • install Joplin on old iPhone and import Joplin data
  • if it all works ...
    ... sync ...
    see what happens

After being busy with work and just not opening Joplin on my phone for several weeks, I tried it again—having changed nothing. Synced worked as one would normally expect. I have no explanation. I'm updating this just in case it's useful to any future users who run into the same mystifying phenomenon.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.