Syncing error with Joplin Cloud and E2EE: "Master Key is not loaded"

Version: Joplin 2.3.5
OS: Mac 10.14.6 (Mojave)
Syncing from Mac to Joplin Cloud (also to mobile, but the problem is originating on the desktop side).

Hey guys! I appreciate Joplin a bunch, and am willing to put the work in to make it work for me. No going back to Evernote, Lord willing...

Unencrypted syncing to Joplin cloud is working fine. But when I enable encryption, the master key will not load. I ran the log report and it appears I am typing the wrong password; that's unfortunate, since I saved it somewhere else immediately after entering it into Joplin—it's possible I typed a character incorrectly, though.

I set up the encryption password for the first time in May; then I never got around to setting up cloud syncing, until I noticed the Joplin Cloud service (such a blessing!). Then, I ran into these problems when I tried to encrypt and sync to Joplin Cloud.

The problem is I can't figure a way to create a new master key using a new password. It's essential that I have E2EE for my job, so if I can't get it figured out I'll likely need to scrap Joplin and find another note app—don't want to do that, though.


Can you provide a screenshot of your Config > Encryption screen please? Is the non-loaded master key with id c917... present in there?

The password is incorrect but you could simply enable encryption again and that would create a new master key. From version 2.4, you can also disable the passwordless master key so that it's hidden and doesn't generate a warning.

Thank you so much!

Perhaps I am doing something wrong. No matter what I type for the password, it does not create a new master key. it seems to expect that I must use the first master key created.

Right, I forgot about that. This is going to be improved in the next version or so, but in the meantime it's true that you'd need to know the original password. Let me check if I can add a fix for this in the pre-release, maybe by allowing to disable any master key, including the active one.

Ok with pre-release 2.4.5 you should be able to get it working:

What you'd do is go to Config > Encryption and then disable that particular master key. Then when you try to enable E2EE again it should no longer ask your for that password, and instead it will create a new master key.

That solved the problem beautifully. Thank you. I'm glad to support you and your work through Joplin Cloud!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.