Joplin portable window stuck on maximised

Operating system


Joplin version


Desktop version info


What issue do you have?

I am using portable version. The window is stuck on maximised. There is no right corner screen button for max/min etc. My only way of changing focus and going to a different application is file/quit. This is drastic. I then have to reload joplin every time. I cannot resize the application window. No taskbar at bottom of screen. The program is though otherwise working. This though does make it unusable. I attach picture which fills the screen. Can someone help me with this problem?


This is odd.

I am not a Windows user (any more) to know if this is possible but do you have any kind of "Tablet Mode" enabled that may hide the title bar?

If not...

You did not give your Desktop Version Info so it is not known what plug-ins you have. In case it is a misbehaving plug-in go to Help > Toggle safe mode to restart Joplin with all plug-ins disabled to see it it becomes normal again. I did not think plug-ins could affect a Windows component like the title bar but if it does work you will have to track down the misbehaving plug-in.

If not...

A long time back there were odd times when Joplin on Windows somehow became resized off the screen. I do not recall this possible "oversize" as a problem before. However, you could trying Quitting Joplin and having a look at the window-state-prod.json file in the JoplinProfile folder. This file is how Joplin remembers its screen position. For full screen on a 1080p monitor the values to the right should be {"x":0,"y":0,"width":1920,"height":1080}}. If it doesn't show these values then you could possibly edit the file however deleting this file when Joplin is shut down will cause it to create a new one with reasonable defaults when next started. As you would be tinkering with config files please export / backup your notes first...

I am having a similar problem, the screen shot posted by robtamp is identical to what I am getting, and the issue is the same.
I am not using the portable version, the problem started after I applied the last upgrade.
I followed the above instructions, Toggle Safe Mode, same thing
I also played around with the window-state-prod.json file (keeping a backup just in case!) to no avail.

I am running Windows 10:
Edition Windows 10 Pro
Version 22H2
Installed on ‎8/‎6/‎2020
OS build 19045.4291
Experience Windows Feature Experience Pack 1000.19056.1000.0

The Joplin version is:
Joplin 2.14.20 (prod, win32)

Client ID: ab5b9b164d9f498bad02d8e8d92fd6cc
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0
Ez Table: 1.0.2
Make All Links: 1.0.3
Templates: 2.4.0

I don't have access to a computer with Windows 10. However, here are some things to try that could give additional information:

1. Trying to switch windows with keyboard shortcuts

Do the Win-Tab and Alt-Tab keyboard shortcuts allow switching windows when Joplin is open?

If Joplin is closed with Alt-F4 then opened from the system tray[1], is the window still fullscreened?

2. Getting window information from Joplin's development tools

It's possible to get additional information about the state of Joplin's main window by running commands in Joplin's development tools. This information may be helpful here, however, it might not be possible to open the developer tools if Joplin's window is stuck in full screen.

  1. Open the developer tools (click Help, then Toggle development tools)
  2. Open the "Console" tab
    • If the developer tools window isn't visible, it may be possible to access it with alt-tab.
  3. Run each of the following and check the output:


  • In general, avoid running untrusted commands in Joplin's development tools.
  • The bridge().window() function provides access to Joplin's main BrowserWindow. The function calls listed above all relate to full-screen windows (documentation).
  • For me, bridge().window().isTabletMode(), bridge().window().isKiosk(), and bridge().window().isFullScreen() return false, while bridge().window().resizable returns true.

3. Trying the pre-release version of Joplin

The 3.0.2 Joplin pre-release uses a newer version of Electron than Joplin 2.14.20. As such, upgrading to v3.0.2 may fix the issue.

:warning: Warning :warning:: Downgrading from v3.0.2 to v2.14.20 can be difficult. As such, I suggest:

  1. Creating a backup.
  2. Testing with Joplin Portable v3.0.2 rather than installing the new version of Joplin.
  3. Copying Joplin Portable to a new directory that does not already have notes before running it.

  1. ↩︎

Thanks dpoulton. I tried all suggestions and your last worked!.

  • Below is the data in my window-state-prod.json file.


  • I changed it to your recommended parameters.
  • Now there is the minimise, maximise option in top right corner of screen.
    Many thanks for your help. I can get back to enjoying this great program.

@Morsed2 welcome to the forum.

Do you have the setting "isFullScreen":true anywhere in the C:\Users\username\.config\joplin-desktop\window-state-prod.json file (not necessarily on the right hand side of the line)?

If so, make sure that Joplin is fully Quit (File > Quit), change true to false and restart Joplin.

The full screen Window you are seeing is what one normally experiences with a browser on Windows after pressing F11. Pressing F11 again restores the browser to normal. However Joplin uses F11 for something else so (1) how full screen mode was triggered in the first place is unclear and (2) you therefore cannot use that key to exit full screen mode, and on Windows (unlike Linux) there does not appear to be another way to do it .

Perfect, thank you.
I had been editing the window-state-prod.json file in the Appdata\Roaming directory.

It is now back to how it was.
Thanks again, have a great day.

Do you have the setting "isFullScreen":true anywhere in the C:\Users\username.config\joplin-desktop\window-state-prod.json file (not necessarily on the right hand side of the line)?

Ans. No. It says False.