Windows 10 Desktop App Invisible Joplin Window

Hi,

On Windows 10, using Joplin Desktop App version 1.0.179 (happens with portable app as well), I get a bug where I open Joplin but the window won’t show up. The Joplin icon appears in the taskbar and the process is running in Task Manager, but I can’t find a way to have the Joplin Window to appear on screen, rendering it unusable.

I tried uninstalling/reinstalling, rebooting etc, but no luck. But if I run Joplin as Admin, then it opens just fine (but it’s not showing my notes since it’s not running as my user).

Anybody experienced that or know how to fix this?

Thanks,

1 Like

see

until then: delete window-state.prod.json from your profile dir (C:\Users\USER\AppData\Roaming\Joplin\).

1 Like

I had this issue as well today. The solution posted by tessus fixed it. Not sure what causes this.

2 issues:

  • I suspect that if several displays are used, the Electron framework sees the other displays as an extension of the first screen. So the coordinates of Joplin will be off-screen when only one display is used (and Joplin ws actually not used on the primary screen).
  • The size issue is still a mystery to me. Although it might be a glitch in the Electron framework as well.

The PR will fix both issues, should there be an issue with the window-state.prod.json file.

Hi,
thank you for the fantastic job first :slight_smile:

For me, removing the window-state.prod.json from C:\Users\USER\AppData\Roaming\Joplin\ directory didn't work.

I've succeeded instead by right-click on the Joplin windows taskbar thumbnail preview and click on the Maximize command.

4 Likes

I just had this problem, and the "maximise from the thumbnail preview" trick worked - thanks.

For me the "maximise " workaround did not work.
Instead I changed the Main Screen to Secondary and Vice versa (via control panel),
and Joplin window appears again normally within the area of my main screen.
Maybe the appearance of the taskbar in both screens affected the framework or some other file/library.

The strangest thing here is that this is still happening.
@tessus was right - this issues appeared only on my multi-monitor setup - after I deleted the folder in C:\Users\USER\AppData\Roaming\Joplin\ it worked like a charm.